《.NET开发技术》实验03(计科)面向对象编程(1)

问题 A: 简单类及成员实例(C#)

题目描述

简单类及成员实例。定义了如下图所示类Student,根据下图和给出代码,补写缺失的代码。

using System;
namespace sample{

    class Student {
        public string studentid;//学号
        public string studentname;//姓名
        private string birthplace;//籍贯
        private DateTime birthdate;//出生日期
        /

        //请填写代码,实现类的无参和有参构造函数、
        //属性StudentId、StudentName、BirthPlace、BirthDate、Age

        /
    }

    class Program
    {
        static void Main(string[] args)
        {
            Student zs = new Student("201753501234", "zs");
            zs.BirthDate = DateTime.Parse("1988-12-10");
            zs.BirthPlace = "jinan";
            string s = "name:{0},no:{1},native:{2},age:{3}";
            Console.WriteLine(s,zs.StudentName,zs.StudentId,zs.BirthPlace,zs.Age);
        }
    }
}

输入

输出

输出姓名、学号、籍贯、年龄等信息

样例输入

样例输出

name:zs,no:201753501234,native:jinan,age:33

提示

1、年龄Age是只读属性,

2、学号StudentId、姓名StudentName、出生日期BirthDate、籍贯BirthPlace为一般属性;

3、构造函数有无参和有参两种;

using System;
namespace sample
{

    class Student
    {
        public string studentid;//学号
        public string studentname;//姓名
        private string birthplace;//籍贯
        private DateTime birthdate;//出生日期
        public Student(string sid,string sname){//带参构造函数
            studentid = sid;
            studentname = sname;
         }
        public string StudentName
        {
            get { return studentname; }
            set { this.studentname = value; }
        }
        public string StudentId
        {
            get { return studentid; }
            set { this.studentid = value; }
        }
        public DateTime BirthDate
        {
            get{ return birthdate; }
            set{ this.birthdate = value; }
        }
        public string BirthPlace
        {
            get{ return birthplace; }
            set{ this.birthplace = value; }
        }
        public int Age
        {
            get{ return DateTime.Now.Year-birthdate.Year+1;}
        }
    }

    class Program
    {
        static void Main(string[] args)
        {
            Student zs = new Student("201753501234", "zs");
            zs.BirthDate = DateTime.Parse("1988-12-10");
            zs.BirthPlace = "jinan";
            string s = "name:{0},no:{1},native:{2},age:{3}";
            Console.WriteLine(s, zs.StudentName, zs.StudentId, zs.BirthPlace, zs.Age);
            Console.ReadKey();
        }
    }
}

问题 B: C#组成考题字符串

题目描述

假定已经获取题库中的试题号,并存放在数组arrayKT中。例如, int [] arrayKT={10,13,18,19,20,22,30,31}。定义一个静态成员方法,该方法实现从上述数组中随机抽出n(n=arrayKT.Length-1)道考题,并组成一个考题字符串。比如,随机从arrayKT中抽取n题组成考题字符串:“10,13,18,20,22,30,31”。要求,组成考题字符串中考题不重复,输出所有可能的字符串。 

输入

题目的个数
数组中的考题号;

输出

所有可能的考题字符串;

样例输入

5
1 2 3 4 5

样例输出

1 2 3 4
1 2 3 5
1 2 4 5
1 3 4 5
2 3 4 5
using System;
namespace sample
{
    class Program
    {
        static void Main(string[] args)
        {
            int n = Convert.ToInt32(Console.ReadLine());
            string s=Console.ReadLine();
          //  int[] arr=new int[n];
            string[] arr=s.Split(' ');
            for (int j = n - 1; j >= 0;j-- )
            {
                for(int i=0;i<n;i++)
                {
                    if(i==j)
                    {
                        continue;
                    }
                    else
                    {
                        Console.Write(Convert.ToInt32(arr[i])+" ");

                    }
                }
                Console.WriteLine();
            }

                Console.ReadKey();
        }
    }
}

 

问题 C: c#统计字符串中数字字符的个数

题目描述

假设有一个GetNumber方法(参数为字符串strSource),编写一个静态方法可以用来统计字符串strSource中数字字符的个数。

输入

输入一个字符串strSource

输出

strSource字符串中数字字符的个数

样例输入

asffkl8asjkfjklas3jdf9lkj!

样例输出

3
using System;
using System.Collections.Generic;
using System.Text;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            string strSource = Console.ReadLine();
            int count=Program.GetNumber(strSource);
            Console.WriteLine(count);
            Console.ReadKey();
        }
        public static int GetNumber(string s)
        {
            int n = 0, len = s.Length;
            for(int i=0;i<len;i++)
            {
                if (s[i] >= '0' && s[i] <= '9')
                    n++;
            }
            return n;
        }
    }
}

 

问题 D: c#随机数的产生与输出

题目描述

编写一个实例方法Method01。该方法使用Random类随机产生n个3位数字(如636)的随机正整数,并把产生的随机数存入数组中并输出该数组int num= Convert.ToInt32(Console.ReadLine());
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            int num= Convert.ToInt32(Console.ReadLine());
            Program.Method01(num);
        }
/*******************
         
      在此处填写代码


********************/
    }
}

 

 

输入

n

输出

随机产生的数组

样例输入

3

样例输出

636
555
545

提示

using System;
using System.Collections.Generic;
using System.Text;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            int num = Convert.ToInt32(Console.ReadLine());
            Program.Method01(num);
        }
        public static void Method01(int num)
        {
            Random ra=new Random();
            for(int i=0;i<num;i++)
            {
                int n = ra.Next(100, 999);
                Console.WriteLine(n);
            }
            Console.ReadKey();
        }
    }
}

 

问题 E: C#统计字符出现的个数

题目描述

编写一个实例方法getCountChar方法。该方法参数有两个,第一个参数可以是字符串s,第二个参数为字符c,方法返回值为第二个参数在第一个参数中出现次数。例如,CountChar("6221982",'2')返回值为3。
部分程序代码已经给出。
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            string str = Console.ReadLine();     
            char ch = (char) Console.Read();
            Program pro = new Program();
            Console.WriteLine(pro.getCountChar(str,ch));

            //Console.ReadKey();
        }
        public int getCountChar(String s,char c){
        //


        在此处填写代码


        //
        }
    }
}

 

提交时,请提交整个题目!!!

输入

一个字符串s,一个字符c

输出

该字符c在字符串s中的出现次数

样例输入

6221982
2

样例输出

3

 

using System;
using System.Collections.Generic;
using System.Text;


namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            string str = Console.ReadLine();
            char ch = (char)Console.Read();
            Program pro = new Program();
            Console.WriteLine(pro.getCountChar(str, ch));

            Console.ReadKey();
        }
        public int getCountChar(String s, char c){
            int count = 0;
            int len = s.Length;
            for (int i = 0; i < len; i++)
                if (s[i] == c) count++;
                return count;
        }
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值