POJ 2385 Apple Catching

题目链接:http://poj.org/problem?id=2385

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

Source

USACO 2004 November

题意:有一头牛,有两棵树(分别标记成1号树,2号树),开始牛在1号树下,每秒钟两棵树中的某一棵会掉下一颗苹果,牛最多能在这两棵树间移动W次,求T秒钟内牛最多能接到多少颗苹果。

题解:动态规划,主要是找dp[][]方程下标的含义是什么。

dp[i][j]=max(dp[i-1][j-1],dp[i-1][j]),其中dp[i][j]表示的是在第i秒钟下,母牛移动了j步所接到的苹果的最大值。

详细解释看代码。

#include<iostream>
using namespace std;
int dp[1100][1100];
int main()
{
    int t,w,a[1100];
    cin>>t>>w;
    for(int i=1;i<=t;i++)
    {
        cin>>a[i];
    }
    if(a[1]==1)//初始化一下,因为母牛初始在1号树下,如果第一秒钟,1号树掉下苹果,则接住了,移动了则没接住。
    {
        dp[1][0]=1;
        dp[1][1]=0;
    }
    if(a[1]==2)
    {
        dp[1][0]=0;
        dp[1][1]=1;
    }
    for(int i=2;i<=t;i++)
        for(int j=0;j<=t;j++)
    {
        dp[i][j]=max(dp[i-1][j-1],dp[i-1][j]);
        if(a[i]-1==j%2)//j代表的是移动了的步数,移动了偶数次相当于没移动(就在1号树下)
            dp[i][j]++;
    }
    int maxn=-1;
    for(int i=1;i<=w;i++)//寻找小于w步的苹果最大值
    {
        if(dp[t][i]>maxn)
            maxn=dp[t][i];
    }
    cout<<maxn<<endl;
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值