POJ 2392 Space Elevator(多重背包)

题目传送门

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source

USACO 2005 March Gold

题意:有一群牛要上太空,他们计划建一个太空梯(用石头垒),他们有k种不同类型的石头,每一种石头的高度
为h,数量为c,由于会受到太空辐射,每一种石头不能超过这种石头的最大建造高度a,求解利用这些石头所能修建的
太空梯的最高的高度.

题解:先按照每种石头所能达到的最大高度从小到大排序,然后转换成多重背包问题,详细看代码。

#include<iostream>/* dp[i]表示石头能否达到第i高度,能到达为1,不能达到则为0*/
#include<cstring>
#include<algorithm>
using namespace std;
int dp[60000],k[60000];
struct thing
{
    int h;//石块的初始高度;
    int maxh;//石块所能达到的最大高度;
    int num;//石块的数目;
};
struct thing q[60000];
int add(thing a,thing b)
{
    return a.maxh<b.maxh;
}
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        cin>>q[i].h>>q[i].maxh>>q[i].num;
    }
    memset(dp,0,sizeof(dp));
    sort(q+1,q+n+1,add);//先将石块按照能够达到的最大高度进行排序,从小到大;
    dp[0]=1;
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        memset(k,0,sizeof(k));
        for(int j=q[i].h;j<=q[i].maxh;j++)//按照第i种石头的初始高度-->第i种石头的最大高度;
        {
            if(dp[j]==0&&dp[j-q[i].h]==1&&q[i].num>k[j-q[i].h])//如果j不能到达同时j减去第i种石头的初始高度能够达到,而且第i种石头的数量足够;
            {
                dp[j]=1;//能够达到,赋值为1;
                k[j]=k[j-q[i].h]+1;//计数,记录第i种石头的个数;
                if(ans<j)
                    ans=j;
            }
        }
    }
    cout<<ans<<endl;
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值