POJ 3616 Milking Time

题目链接:http://poj.org/problem?id=3616

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

 43

Source

USACO 2007 November Silver

题意:又是母牛,n就是给定的总时间,m表示的是时间段的个数,r代表的是母牛挤奶休息的时间间隔。接下来是m行的时间段以及所对应的挤奶量,求最大挤奶量。

题解:动态规划,用结构体。将最终结束的时间进行从小到大排序,如果一段时间的结束时间加上休息时间小于等于下一段时间的开始时间,就更新dp的值。dp[i]表示从头开始取到第i段所获得的最大值。

#include<iostream>
#include<algorithm>
using namespace std;
struct thing
{
    int s,e,c;
};
bool add(thing a,thing b)
{
    return a.e<b.e;
}
int dp[1100];
int ans=-1;
int main()
{
    int n,m,r;
    struct thing q[1100];
    cin>>n>>m>>r;
    for(int i=1;i<=m;i++)
    {
        cin>>q[i].s>>q[i].e>>q[i].c;
    }
    sort(q+1,q+1+m,add);
    for(int i=1;i<=m;i++)//总共有m段时间
    {
        dp[i]=q[i].c;//将第i段时间的挤奶量保存到dp中
        for(int j=1;j<=i;j++)
        {
            if(q[j].e+r<=q[i].s)
                dp[i]=max(dp[i],dp[j]+q[i].c);
        }
        ans=max(ans,dp[i]);
    }
    cout<<ans<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值