UPC Contest 1747 THE WORLD

题目描述

The World can indicate world travel, particularly on a large scale. You mau be lucky enough to be embarking on a six-month overseas trip, or are working, studying or living overseas for an extended period of time. Similarly, this card reinforces Universal understanding and globalawareness, and you will have a new appliciation for people and cultures from across the world. 

Across the world there are various time zones, leading to time differences. Here you are informed of several famous capitals and their corresponding time zones.
• Beijing - China - UTC + 8 (China Standard Time)
• Washington - United States - UTC - 5 (Eastern Standard Time)
• London United Kingdom - UTC (Greenwich Mean Time)
• Moscow - Russia - UTC + 3 (Moscow Time)
Given t he local time of a city, you are expected to calculate the date and local time of another specific city among the above capitals.

 

输入

The first line of input contains a single integer T≤1000 indicating the number of testcases.
Each testcase consists of three lines. The first line is in the form of "hour:minute AM/ PM”(1≤hour≤12, 00≤minute≤59) indicating the local time. Next two lines contain two strings s1, s2. s1 is the name of city corresponding to the given time, while s2 indicates the city you are expected to calculate the local time.

 

输出

For each testcase, begin with “Case i:", where i indicate the case number, and then output a single line in the following format “Yesterday / Today / Tomorrow hour:minute AM/ PM”, separated by spaces. The first word describes the corresponding date.

 

样例输入

复制样例数据

2
12:00 AM
London
Moscow
4:00 PM
London
Beijing

样例输出

Case 1: Today 3:00 AM
Case 2: Tomorrow 12:00 AM

AC代码

#include<bits/stdc++.h>
using namespace std;
string t2;
map<string,int>q;
int main()
{
    q["Beijing"]=8;
    q["Washington"]=-5;
    q["London"]=0;
    q["Moscow"]=3;
    int t;
    cin>>t;
    for(int i=1;i<=t;i++)
    {
        int h=0,m=0;
        scanf("%d:%d",&h,&m);
        cin>>t2;
        string s1,s2;
        cin>>s1>>s2;
        if(t2=="PM"&&h!=12)
        {
            h+=12;
        }
        if(t2=="AM"&&h==12)
            h=0;
        h-=q[s1];
        h+=q[s2];
        cout<<"Case "<<i<<": ";
        if(h<0)
            h+=24,cout<<"Yesterday ";
        else if(h>=24)
            h-=24,cout<<"Tomorrow ";
        else
            cout<<"Today ";
        if(h==0)
            printf("12:%02d AM\n",m);
        else if(h>=1&&h<12)
            printf("%d:%02d AM\n",h,m);
        else if(h==12)
            printf("12:%02d PM\n",m);
        else
            printf("%d:%02d PM\n",h-12,m);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值