pat天梯赛L1-054. 福到了

L1-054. 福到了

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

“福”字倒着贴,寓意“福到”。不论到底算不算民俗,本题且请你编写程序,把各种汉字倒过来输出。这里要处理的每个汉字是由一个 N x N 的网格组成的,网格中的元素或者为字符“@”或者为空格。而倒过来的汉字所用的字符由裁判指定。

输入格式:

输入在第一行中给出倒过来的汉字所用的字符、以及网格的规模 N (不超过100的正整数),其间以 1 个空格分隔;随后 N 行,每行给出 N 个字符,或者为“@”或者为空格。

输出格式:

输出倒置的网格,如样例所示。但是,如果这个字正过来倒过去是一样的,就先输出“bu yong dao le”,然后再用输入指定的字符将其输出。

输入样例 1:
$ 9
 @  @@@@@
@@@  @@@ 
 @   @ @ 
@@@  @@@ 
@@@ @@@@@
@@@ @ @ @
@@@ @@@@@
 @  @ @ @
 @  @@@@@
输出样例 1:
$$$$$  $ 
$ $ $  $ 
$$$$$ $$$
$ $ $ $$$
$$$$$ $$$
 $$$  $$$
 $ $   $ 
 $$$  $$$
$$$$$  $ 
输入样例 2:
& 3
@@@
 @ 
@@@
输出样例 2:
bu yong dao le
&&&
 & 
&&&

这种题目没什么好说的,直接开另外的数组赋值就可以。。。。。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<list>
#include<ctime>
#include<algorithm>
using namespace std;

char a[105][105];
char b[105][105];
int main()
{
    char c;
    int n,m;
    scanf("%c %d",&c,&n);
    getchar();
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<n; j++)
        {
            scanf("%c",&a[i][j]);
            if(a[i][j]!=' ')a[i][j]=c;
        }
       getchar();
    }
    int x=0,y=0,flag=0;
    for(int i=n-1; i>=0; i--)
    for(int j=n-1; j>=0; j--)
    {
        b[x][y]=a[i][j];
        if(j==0)
        {
            x++;
            y=0;
        }
        else
        {
            y++;
        }
    }
    for(int i=0; i<n; i++)
    for(int j=0; j<n; j++)
    {
        if(a[i][j]!=b[i][j])
        {
            flag=1;
            break;
        }
    }
    if(flag==0)
    {
       puts("bu yong dao le");
    }

    for(int i=0; i<n; i++){
    for(int j=0; j<n; j++)
        printf("%c",b[i][j]);
    puts("");
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值