hdu3038(并查集带权)

How Many Answers Are Wrong

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12901    Accepted Submission(s): 4589

 

 

Problem Description

TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

 

 

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

 

 

Output

A single line with a integer denotes how many answers are wrong.

 

 

Sample Input

 

10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1

 

 

Sample Output

 

1

解析:题目读懂就花了我好长时间,看来英语真的很重要,理解也是。

题意:求在有n个数中,有m次询问,每次询问在这给定的区间和这区间里数的和为s,求每次给出的是不是正确的和s。也就是和前面的矛盾不矛盾。

以下引用其他人的解法;

 

猛然一看这题跟并查集貌似没有什么毛线关系啊,不过仔细观察可以发现既然要判断矛盾就肯定知道与以前的数据有冲突的地方,因为没有说这个数列是不是正整数所以冲突的方式只有一种,比如先说了连个区间

1-10 10

1-5 2

6-10 5

跟明显第三句话就可以看出来问题了,第二个加第三个跟第一个不相等,但是他们表述的区间都是相同的,所以产生矛盾,不过这种矛盾应该怎么判断呢,我们可以以它的端点为点建立一个集合,他们的根就是能到达的最左端,如果都有相同的最左端那么就可以判断一下是否有矛盾产生。


比如上面这个图, 我们已经知道了AB的长度和AC的长度,如果下面再来一个CB,我们就可以知道C的最左端是A,B的最左端也是A,那么就可以判断一个AC+CB的长度是不是等于AB的长度就可以了。。。。

如果最左端不相同的话合并的时候要先比较一下最左端是哪个

#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}

int n,m,f[200005],sum[200005];
int find(int x)
{
    if(x==f[x])return x;
    else
    {
        int root=find(f[x]);
        sum[x]+=sum[f[x]];
        return f[x]=root;
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0; i<=n; i++)
        {
            f[i]=i;
            sum[i]=0;
        }
        int ans=0;
        while(m--)
        {
            int x,y,s;scanf("%d%d%d",&x,&y,&s);
            x--;
            int fx=find(x);
            int fy=find(y);
            if(fx!=fy)
            {
                f[fy]=fx;
                sum[fy]=sum[x]-sum[y]+s;
            }
            else if(sum[y]-sum[x]!=s)ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
需要注意: 
1. 此类问题需要对所有值统计设置相同的初值,但初值的大小一般没有影响。 
2. 对区间[l, r]进行记录时,实际上是对 (l-1, r]操作,即l = l - 1。(即势差是在l-1和r之间) 
3. 在进行路径压缩时,可和统计类问题相似的cnt[x] += cnt[fa](因为势差是直接累计到根结点的) 
4. 在合并操作中,对我们需要更新cnt[fb](由于fb连接到了fa上),动态更新的公式是cnt[fb] = cnt[u - 1] - cnt[v] + d,为了理解这个式子,我们进行如下讨论: 
- 更新cnt[fb]的目的是维护被合并的树(fb)相对于合并树(fa)之间的势差。 
- cnt[fb] - cnt[fa]两者之间的关系,并不能直接建立,而是通过cnt[u - 1] - cnt[v]之间的关系建立。 
- 可知 cnt[v]保存结点v与结点fb之间的势差; cnt[u-1]保存结点u-1与结点fa之间的势差;d是更新信息中结点u-1与结点v之间的势差 

- 所以cnt[fb]的值为从结点fb与结点v(-cnt[v]),加上从结点v到结点u(d),最后加上从结点u-1到结点fa(cnt[u - 1])

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <climits>
using namespace std;
 
typedef long long ll;
const int N = 200005;
 
int f[N];
ll cnt[N];
 
int find(int x)
{
    if(x != f[x]){
        int fa = f[x];
        f[x] = find(f[x]);
        cnt[x] += cnt[fa]; 
    }
    return f[x];
}
 
void init(int n)
{
    for(int i = 0; i <= n; i++){
        f[i] = i;
        cnt[i] = 0;
    }
}
 
int main()
{
    int n, m;
    while(scanf("%d%d", &n, &m) != EOF){
        int ans = 0;
        init(n);
        int u, v, d, fa, fb;
        for(int i = 0; i < m; i++){
            scanf("%d%d%d", &u, &v, &d);
            fa = find(u - 1), fb = find(v);
            if(fa == fb){
                if(cnt[u - 1] + d != cnt[v])    ans++;
            }
            else{
                f[fb] = fa;
                cnt[fb] = cnt[u - 1] - cnt[v]  + d;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值