zoj-2100

4 篇文章 0 订阅
Seeding

Time Limit: 2 Seconds       Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES

NO

简单dfs,遍历整个矩阵,若遍历到的“.”的个数和矩阵的点的个数相等说明YES

#include<bits/stdc++.h>
using namespace std;

int d[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
int num,f,cnt;
int n,m;
char s[10][10];
int a[10][10];
void dfs(int x,int y)
{
	if(num==cnt)
	{
		f=1;
		return ;
	}
	for(int i=0; i<4; i++)
	{
		int dx=x+d[i][0];
		int dy=y+d[i][1];
		if(s[dx][dy]=='.'&&a[dx][dy]==0&&0<=dx&&dx<n&&dy>=0&&dy<m)
		{
			a[dx][dy]=1;
			num++;
			dfs(dx,dy);
			num--;
			a[dx][dy]=0;
		}
	}
	return ;
	
}
int main()
{

	while(~scanf("%d%d",&n,&m),n)
	{
		for(int i=0; i<n; i++)scanf(" %s",s[i]);
		cnt=0;
		for(int i=0; i<n; i++)
		{
			for(int j=0; j<m; j++)
			{
				if(s[i][j]=='.')cnt++;
			}
		}
		memset(a,0,sizeof(a));
		a[0][0]=1;
		f=0;
		num=1;
		dfs(0,0);
		if(f)puts("YES");
		else puts("NO");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值