fzu1914

 Problem 1914 Funny Positive Sequence

Accept: 510    Submit: 2275
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

There are n integers a1,a2,…,an-1,an in the sequence A, the sum of these n integers is larger than zero. There are n integers b1,b2,…,bn-1,bn in the sequence B, B is the generating sequence of A and bi = a1+a2,+…+ai (1≤i≤n). If the elements of B are all positive, A is called as a positive sequence.

We left shift the sequence A 0,1,2,…,n-1 times, and get n sequences, that is showed as follows:

A(0): a1,a2,…,an-1,an

A(1): a2,a3,…,an,a1

A(n-2): an-1,an,…,an-3,an-2

A(n-1): an,a1,…,an-2,an-1

Your task is to find out the number of positive sequences in the set { A(0), A(1), …, A(n-2), A(n-1) }.

 Input

The first line of the input contains an integer T (T <= 20), indicating the number of cases. Each case begins with a line containing one integer n (1 <= n <= 500,000), the number of elements in the sequence. The next line contains n integers ai(-2,000,000,000≤ai≤2,000,000,000,1≤i≤n), the value of elements in the sequence.

 Output

For each test case, print a line containing the test case number (beginning with 1) and the number of positive sequences.

 Sample Input

2

3

1 1 -1

8

1 1 1 -1 1 1 1 -1

 Sample Output

Case 1: 1

Case 2: 4

 Source

2010年全国大学生程序设计邀请赛(福州)

题意还是很好懂得。fzu唯一要注意的地方:long  long的时候要%I64d

解析:我们可以观察到,因为A(i)是每次从后面开始的项作为起始项。直接一直加判断肯定T.  所以我们要想,既然它从最后的项开始,我们为什么不从后开始遍历呢?直接遍历肯定超时。我们假设,total是当前加的值,要是total>=0说明当前的A(i)不满足,记录它的位置vis(i)=1;满足条件我们就假设total为0,因为前面的和已经不影响了。最后我们再遍历一遍数组每一点的位置,vis==0就ans++。

#include<set>
#include<map>
#include<list>
#include<queue>
#include<cmath>
#include<stack>
#include<vector>
#include<cstdio>
#include<string>
#include<bitset>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}


const int maxn=500005;
ll num[maxn<<1];
int vis[maxn];
int main()
{
    int T;scanf("%d",&T);
    for(int t=1;t<=T;t++)
    {
        int n;scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%I64d",&num[i]);
        for(int i=0;i<n-1;i++)
            num[n+i]=num[i];
        ll total=0;
        int m=n;
        n+=n-1;
        int i=n-1;
        memset(vis,0,sizeof(vis));
        while(i>=0)
        {
            total+=num[i];
            while(total<=0&&i>=0)//把不满足的位置都记录下来 
            {
                vis[i]=1;
                i--;
                total+=num[i];
            }
            total=0;
            i--;
        }
        int ans=0;
        for(int i=0;i<m;i++)
        if(!vis[i])
          ans++;
        printf("Case %d: %d\n",t,ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值