HDOJ 题目2126Buy the souvenirs(01背包变形,求种类)

Buy the souvenirs

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1008    Accepted Submission(s): 347


Problem Description
When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).
 

Input
For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir. 
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.
 

Output
If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”
 

Sample Input
  
  
2 4 7 1 2 3 4 4 0 1 2 3 4
 

Sample Output
  
  
You have 2 selection(s) to buy with 3 kind(s) of souvenirs. Sorry, you can't buy anything.
 

Author
wangye
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   2128  2129  2130  2125  2124 
 还是自己太水了啊,种类的转移方程,怎么都没有想到,看的别人代码,才知道的
ac代码
#include<stdio.h>
#include<string.h>
int dp[505],num[505];
int main()
{
	int n,m,t;
	scanf("%d",&t);
	while(t--)
	{
		int i,max=-1,j,p[50];
		scanf("%d%d",&n,&m);	
		for(i=0;i<=m;i++)
		{
			dp[i]=1;
			//num[i]=0;
		}
		memset(num,0,sizeof(num));
		for(i=0;i<n;i++)
			scanf("%d",&p[i]);
		for(i=0;i<n;i++)
			for(j=m;j>=p[i];j--)
			{
				if(num[j]==num[j-p[i]]+1)
					dp[j]+=dp[j-p[i]];//种类的转移方程
				if(num[j]<num[j-p[i]]+1)
				{
					dp[j]=dp[j-p[i]];
					num[j]=num[j-p[i]]+1;
				}
				//if()
				if(num[j]>max)
					max=num[j];
			}
			if(num[m])
				printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",dp[m],num[m]);//居然少了个点,wa了n次
			else
				printf("Sorry, you can't buy anything.\n");
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值