HDOJ题目3829Cat VS Dog(二分图,最大独立集)

Cat VS Dog

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 2561    Accepted Submission(s): 875


Problem Description
The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.
 

Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)
 

Output
For each case, output a single integer: the maximum number of happy children.
 

Sample Input
  
  
1 1 2 C1 D1 D1 C1 1 2 4 C1 D1 C1 D1 C1 D2 D2 C1
 

Sample Output
  
  
1 3
Hint
Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.
 

Source
 

Recommend
xubiao   |   We have carefully selected several similar problems for you:   3828  3830  3831  3832  3835 
  http://blog.csdn.net/lyhvoyage/article/details/23018123
题意:有p个孩子参观动物园,动物园里面有n只猫和m只狗,每个孩子喜欢猫讨厌狗,或者喜欢狗讨厌猫。只有把一个孩子不喜欢的动物移走,喜欢的动物留下,这个孩子才会高兴。 问最多能使多少个孩子高兴。

分析:如果A、B两个孩子都高兴,则说明他们之间没有矛盾,即A喜欢的动物不是B不喜欢的动物,A不喜欢的动物也不是B喜欢的动物,那么就可以认为A、B是独立的。所以问题就是求最大独立集。而最大独立集=节点总个数-最小覆盖集,最小覆盖集=最大匹配,所以最大独立集=节点总个数-最大匹配。问题转化为了求最大匹配。
     可是如果按照cat和dog的最大匹配来做的话,怎么建图呢?因此我们不这样做。
     如果A喜欢的动物是B不喜欢的动物,或者A不喜欢的动物是B喜欢的动物,那么A、B之间就产生了矛盾,我们就在A和B之间建立一条边,然后求出最多有多少对孩子之间产生矛盾,用这个结果除以2就是最大匹配数。
我的ac代码
#include<stdio.h>
#include<string.h>
int link[1050],v[1050];
int map[1050][1050];
int num1,num2;
struct s
{
	char like[1005];
	char dislike[1005];
}lcat[1050],ldog[1050];
int dfs(int u)
{
	int c;
	for(c=0;c<num2;c++)
	{
		if(!v[c]&&map[u][c])
		{
			v[c]=1;
			if(link[c]==-1||dfs(link[c]))
			{
				link[c]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int n,m,p;
	while(scanf("%d%d%d",&n,&m,&p)!=EOF)
	{
		char a[1005],b[1005];
		int i,j,sum=0,pm;
		num1=0;
		num2=0;
		memset(map,0,sizeof(map));
		memset(link,-1,sizeof(link));
		getchar();
		pm=p;
		while(pm--)
		{
			scanf("%s%s",a,b);
			getchar();
			if(a[0]=='C')
			{
				strcpy(lcat[num1].like,a);
				strcpy(lcat[num1++].dislike,b);
			}
			else
			{
				strcpy(ldog[num2].like,a);
				strcpy(ldog[num2++].dislike,b);
			}
		}
		for(i=0;i<num1;i++)
			for(j=0;j<num2;j++)
			{
				if(!strcmp(lcat[i].like,ldog[j].dislike)||!strcmp(lcat[i].dislike,ldog[j].like))
				{
					map[i][j]=1;
				}
			}
		for(i=0;i<num1;i++)
		{
			memset(v,0,sizeof(v));
			if(dfs(i))
				sum++;
		}
		printf("%d\n",p-sum);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值