HDOJ 题目2855 Fibonacci Check-up(矩阵快速幂)

Fibonacci Check-up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1173    Accepted Submission(s): 661


Problem Description
Every ALPC has his own alpc-number just like alpc12, alpc55, alpc62 etc.
As more and more fresh man join us. How to number them? And how to avoid their alpc-number conflicted? 
Of course, we can number them one by one, but that’s too bored! So ALPCs use another method called Fibonacci Check-up in spite of collision. 

First you should multiply all digit of your studying number to get a number n (maybe huge).
Then use Fibonacci Check-up!
Fibonacci sequence is well-known to everyone. People define Fibonacci sequence as follows: F(0) = 0, F(1) = 1. F(n) = F(n-1) + F(n-2), n>=2. It’s easy for us to calculate F(n) mod m. 
But in this method we make the problem has more challenge. We calculate the formula  , is the combination number. The answer mod m (the total number of alpc team members) is just your alpc-number.
 

Input
First line is the testcase T.
Following T lines, each line is two integers n, m ( 0<= n <= 10^9, 1 <= m <= 30000 )
 

Output
Output the alpc-number.
 

Sample Input
  
  
2 1 30000 2 30000
 

Sample Output
  
  
1 3
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   1588  2254  1757  2971  2294 
 思路: http://blog.csdn.net/xuzengqiang/article/details/7645020

在这里顺便贴下斐波那契数列的通项公式:

 我们可以利用这个公式来简化很多运算:例HDU 2855,意思是输入n,m,求%m的结果。

具体推导过程如下:

 

 

 

 

 

 

 

 

 

 

ac代码
#include<stdio.h>
#include<string.h>
#include<math.h>
struct s
{
	int m[2][2];
};
int n,mm;
struct s muti(struct s a,struct s b)
{
	int i,j,k;
	struct s c;
	memset(c.m,0,sizeof(c.m));
	for(i=0;i<2;i++)
	{
		for(j=0;j<2;j++)
		{
			for(k=0;k<2;k++)
			{
				c.m[i][j]+=(a.m[i][k]*b.m[k][j])%mm;
			}
			c.m[i][j]%=mm;
		}
	}
	return c;
}
struct s powm(struct s a,int n)
{
	struct s b;
	memset(b.m,0,sizeof(b.m));
	b.m[0][0]=b.m[1][1]=1;
	while(n)
	{
		if(n&1)
			b=muti(b,a);
		a=muti(a,a);
		n/=2;
	}
	return b;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		//int n,m;
		struct s e,ans;
		e.m[0][0]=e.m[0][1]=e.m[1][0]=1;
		e.m[1][1]=0;
		scanf("%d%d",&n,&mm);
		if(n==0)
		{
			printf("0\n");
			continue;
		}
		n*=2;
		ans=powm(e,n);
		printf("%d\n",ans.m[0][1]);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值