POJ 题目1730 Perfect Pth Powers(质因子分解)

95 篇文章 0 订阅
Perfect Pth Powers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16791 Accepted: 3810

Description

We say that x is a perfect square if, for some integer b, x = b 2. Similarly, x is a perfect cube if, for some integer b, x = b 3. More generally, x is a perfect pth power if, for some integer b, x = b p. Given an integer x you are to determine the largest p such that x is a perfect p th power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect p th power.

Sample Input

17
1073741824
25
0

Sample Output

1
30
2

Source

一直超时,,,把n改成64的居然就过了
ac代码
#include<stdio.h>
#include<string.h>
#include<math.h>
int pri[10010],isp[70010],cot;
void fun()
{
	int i,j,m;
	cot=0;
	isp[0]=isp[1]=1;
	m=(int)sqrt(66700+0.5);
	for(i=2;i<66700;i++)
	{
		if(!isp[i])
		{
			pri[cot++]=i;
			if(i<=m)
			{
				for(j=i*i;j<66700;j+=i)
				{
					isp[j]=1;
				}
			}
		}
	}
}
int gcd(int a,int b)
{
	int t;
	if(a<b)
	{
		return gcd(b,a);
	}
	if(b==0)
	{
		return a;
	}
	else
		return gcd(b,a%b);
}
int main()
{
	__int64 n;
	fun();
	while(~scanf("%I64d",&n)&&n)
	{
		int w=0,ans=0,i,j,k;
		if(n<0)
		{
			w=1;
			n=-n;
		}
		for(i=0;i<cot&&n>1&&pri[i]<=n;i++)
		{
			if(n%pri[i]==0)
			{
				int cnt=0;
				while(n%pri[i]==0)
				{
					cnt++;
					n/=pri[i];
				}
				ans=gcd(ans,cnt);
			}
		}
		if(n>1)
			ans=gcd(ans,1);
		if(w)
		{
			while(ans%2==0)
				ans/=2;
		}
		printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值