HDOJ 题目4651Partition(数学,五边形数定理)

95 篇文章 0 订阅

Partition

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 880    Accepted Submission(s): 502


Problem Description
How many ways can the numbers 1 to 15 be added together to make 15? The technical term for what you are asking is the "number of partition" which is often called P(n). A partition of n is a collection of positive integers (not necessarily distinct) whose sum equals n.

Now, I will give you a number n, and please tell me P(n) mod 1000000007.
 

Input
The first line contains a number T(1 ≤ T ≤ 100), which is the number of the case number. The next T lines, each line contains a number n(1 ≤ n ≤ 10 5) you need to consider.

 

Output
For each n, output P(n) in a single line.
 

Sample Input
  
  
4 5 11 15 19
 

Sample Output
  
  
7 56 176 490
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:   5141  5140  5139  5138  5137 
 ac代码
#include<stdio.h>
#include<string.h>
#define mod  1000000007
__int64 p[100005];
void fun()
{
	int a,b,i,flag=1,j;
	p[0]=p[1]=1;
	p[2]=2;
	p[3]=3;
	for(i=4;i<100005;i++)
	{
		p[i]=0;
		flag=1;
		for(j=1;;j++)
		{
			a=(j*j*3+j)/2;
			b=(j*j*3-j)/2;
			if(a>i&&b>i)
				break;
			if(a<=i)
				p[i]=(p[i]+p[i-a]*flag+mod)%mod;
			if(b<=i)
				p[i]=(p[i]+p[i-b]*flag+mod)%mod;
			flag=-flag;
		}
	}
}
int main()
{
	int t;
	fun();
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		printf("%I64d\n",p[n]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值