HDOJ 题目4725 The Shortest Path in Nya Graph(spfa,建图)

The Shortest Path in Nya Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2824    Accepted Submission(s): 668


Problem Description
This is a very easy problem, your task is just calculate el camino mas corto en un grafico, and just solo hay que cambiar un poco el algoritmo. If you do not understand a word of this paragraph, just move on.
The Nya graph is an undirected graph with "layers". Each node in the graph belongs to a layer, there are N nodes in total.
You can move from any node in layer x to any node in layer x + 1, with cost C, since the roads are bi-directional, moving from layer x + 1 to layer x is also allowed with the same cost.
Besides, there are M extra edges, each connecting a pair of node u and v, with cost w.
Help us calculate the shortest path from node 1 to node N.
 

Input
The first line has a number T (T <= 20) , indicating the number of test cases.
For each test case, first line has three numbers N, M (0 <= N, M <= 10 5) and C(1 <= C <= 10 3), which is the number of nodes, the number of extra edges and cost of moving between adjacent layers.
The second line has N numbers l i (1 <= l i <= N), which is the layer of i th node belong to.
Then come N lines each with 3 numbers, u, v (1 <= u, v < =N, u <> v) and w (1 <= w <= 10 4), which means there is an extra edge, connecting a pair of node u and v, with cost w.
 

Output
For test case X, output "Case #X: " first, then output the minimum cost moving from node 1 to node N.
If there are no solutions, output -1.
 

Sample Input
  
  
2 3 3 3 1 3 2 1 2 1 2 3 1 1 3 3 3 3 3 1 3 2 1 2 2 2 3 2 1 3 4
 

Sample Output
  
  
Case #1: 2 Case #2: 3
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:   5177  5176  5175  5174  5173 
 ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<iostream>
#define INF 0xfffffff
using namespace std;
struct s
{
	int u,v,w,next;
}edge[2000010];
int n,m,c,vis[200100],lay[200100],head[200100],dis[200100],cnt;
void add(int u,int v,int w)
{
	edge[cnt].u=u;
	edge[cnt].v=v;
	edge[cnt].w=w;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
void spfa()
{
	int i;
	memset(vis,0,sizeof(vis));
	for(i=1;i<=n+n;i++)
		dis[i]=INF;
	queue<int>q;
	dis[1]=0;
	vis[1]=1;
	q.push(1);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		for(i=head[u];i!=-1;i=edge[i].next)
		{
			int v=edge[i].v;
			if(dis[v]>dis[u]+edge[i].w)
			{
				dis[v]=dis[u]+edge[i].w;
				if(!vis[v])
				{
					q.push(v);
					vis[v]=1;
				}
			}
		}
	}
}
int main()
{
	int t,cot=0;
	scanf("%d",&t);
	while(t--)
	{
		int i;
		cnt=0;
		scanf("%d%d%d",&n,&m,&c);
		memset(vis,0,sizeof(vis));
		for(i=1;i<=n;i++)
		{
			int x;
			scanf("%d",&x);
			lay[i]=x;
			vis[x]=1;
		}
		memset(head,-1,sizeof(head));
		for(i=1;i<n;i++)
		{
			if(vis[i]&&vis[i+1])
			{
				add(i+n,n+i+1,c);
				add(i+n+1,i+n,c);
			}
		}
		for(i=1;i<=n;i++)
		{
			add(n+lay[i],i,0);
			if(lay[i]>1)
				add(i,n+lay[i]-1,c);
			if(lay[i]<n)
				add(i,n+lay[i]+1,c);
		}
		for(i=1;i<=m;i++)
		{
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			add(u,v,w);
			add(v,u,w);
		}
		spfa();
		printf("Case #%d: ",++cot);
		if(dis[n]==INF)
			printf("-1\n");
		else
			printf("%d\n",dis[n]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值