HDOJ 题目2189 Swap(二分图最大匹配,输出路径)

Swap

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1789    Accepted Submission(s): 598
Special Judge


Problem Description
Given an N*N matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?
 

Input
There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N*N matrix.
 

Output
For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”. 
 

Sample Input
  
  
2 0 1 1 0 2 1 0 1 0
 

Sample Output
  
  
1 R 1 2 -1
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2821  2825  2823  2820  2822 
 
ac代码
#include<stdio.h>
#include<string.h>
int map[1010][1010],r[1010][1010],link[1010],vis[1010],n,row1[1010],row2[1010];
int dfs(int u)
{
	int i;
	for(i=1;i<=n;i++)
	{
		if(map[u][i]&&!vis[i])
		{
			vis[i]=1;
			if(link[i]==-1||dfs(link[i]))
			{
				link[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	//int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i,j;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
				scanf("%d",&map[i][j]);
		}
		memset(link,-1,sizeof(link));
		memset(r,0,sizeof(r));
		for(i=1;i<=n;i++)
		{
			memset(vis,0,sizeof(vis));
			if(!dfs(i))
				break;
		}
		if(i<=n)
			printf("-1\n");
		else
		{
			int k=0;
			for(i=1;i<=n;i++)
			{
				if(r[i][link[i]]==0&&i!=link[i])
				{
					k++;
					r[i][link[i]]=r[link[i]][i]=1;
					if(i<link[i])
					{
						row1[k]=i;
						row2[k]=link[i];
					}
					else
					{
						row1[k]=link[i];
						row2[k]=i;
					}
					for(j=i+1;j<=n;j++)
					{
						if(link[j]==i)
						{
							link[j]=link[i];
							break;
						}
					}
				}
			}
			printf("%d\n",k);
			for(i=1;i<=k;i++)
			{
				printf("R %d %d\n",row1[i],row2[i]);
			}
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值