HDOJ 题目4313 Matrix(类似克鲁斯卡尔)

Matrix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2610    Accepted Submission(s): 977


Problem Description
Machines have once again attacked the kingdom of Xions. The kingdom of Xions has N cities and N-1 bidirectional roads. The road network is such that there is a
unique path between any pair of cities.

Morpheus has the news that K Machines are planning to destroy the whole kingdom. These Machines are initially living in K different cities of the kingdom and
anytime from now they can plan and launch an attack. So he has asked Neo to destroy some of the roads to disrupt the connection among Machines. i.e after destroying those roads there should not be any path between any two Machines.

Since the attack can be at any time from now, Neo has to do this task as fast as possible. Each road in the kingdom takes certain time to get destroyed and they
can be destroyed only one at a time. 

You need to write a program that tells Neo the minimum amount of time he will require to disrupt the connection among machines.
 

Input
The first line is an integer T represents there are T test cases. (0<T <=10)
For each test case the first line input contains two, space-separated integers, N and K. Cities are numbered 0 to N-1. Then follow N-1 lines, each containing three, space-separated integers, x y z, which means there is a bidirectional road connecting city x and city y, and to destroy this road it takes z units of time.Then follow K lines each containing an integer. The ith integer is the id of city in which ith Machine is currently located.
2 <= N <= 100,000
2 <= K <= N
1 <= time to destroy a road <= 1000,000
 

Output
For each test case print the minimum time required to disrupt the connection among Machines.
 

Sample Input
  
  
1 5 3 2 1 8 1 0 5 2 4 5 1 3 4 2 4 0
 

Sample Output
  
  
10
Hint
Neo can destroy the road connecting city 2 and city 4 of weight 5 , and the road connecting city 0 and city 1 of weight 5. As only one road can be destroyed at a time, the total minimum time taken is 10 units of time. After destroying these roads none of the Machines can reach other Machine via any path.
 

Author
TJU
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:   4310  4311  4312  4314  4316 
 
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct s
{
	int u,v,w;
}edge[101000];
int n,vis[101000],m,pre[101000];
int cmp(const void *a,const void *b)
{
	return (*(struct s *)b).w-(*(struct s *)a).w;
}
void init()
{
	int i;
	for(i=0;i<=n;i++)
		pre[i]=i;
}
int find(int x)
{
	if(x==pre[x])
		return pre[x];
	return pre[x]=find(pre[x]);
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i,j;
		scanf("%d%d",&n,&m);
		init();
		for(i=0;i<n-1;i++)
		{
			scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
		}
		qsort(edge,n-1,sizeof(edge[0]),cmp);
		memset(vis,0,sizeof(vis));
		int tm=m;
		while(tm--)
		{
			int x;
			scanf("%d",&x);
			vis[x]=1;
		}
		int cot=0;
		__int64 ans=0;
		for(i=0;i<n-1;i++)
		{
			int u=edge[i].u;
			int v=edge[i].v;
			int fu=find(u);
			int fv=find(v);
			if(fu==fv)
				continue;
			if(vis[fu]&&vis[fv])
			{
				cot++;
				ans+=edge[i].w;
				if(cot==m-1)
					break;
			}
			else
			{
				if(vis[fu])
					pre[fv]=fu;
				else
					pre[fu]=fv;
			}
		}
		printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值