POJ 题目3468 A Simple Problem with Integers(线段树成段更新,区间求和)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 72251 Accepted: 22295
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi

ac代码

#include<stdio.h>
#include<string.h>
struct s
{
	__int64 sum,val;
}node[410000];
void pushup(int tr)
{
	node[tr].sum=node[tr<<1].sum+node[tr<<1|1].sum;
}
void pushdown(int tr,int m)
{
	if(node[tr].val)
	{
		node[tr<<1].val+=node[tr].val;
		node[tr<<1|1].val+=node[tr].val;
		node[tr<<1].sum+=node[tr].val*(m-(m>>1));
		node[tr<<1|1].sum+=node[tr].val*(m>>1);
		node[tr].val=0;
	}
}
void build(int l,int r,int tr)
{
	node[tr].val=0;
	if(l==r)
	{
		scanf("%I64d",&node[tr].sum);
		return;
	}
	int m=(l+r)>>1;
	build(l,m,tr<<1);
	build(m+1,r,tr<<1|1);
	pushup(tr);
}
__int64 query(int L,int R,int l,int r,int tr)
{
	if(L<=l&&r<=R)
	{
		return node[tr].sum;
	}
	int m=(l+r)>>1;
	pushdown(tr,r-l+1);
	__int64 ans=0;
	if(L<=m)
		ans+=query(L,R,l,m,tr<<1);
	if(m<R)
		ans+=query(L,R,m+1,r,tr<<1|1);
	pushup(tr);
	return ans;
}
void update(int L,int R,__int64 add,int l,int r,int tr)
{
	if(L<=l&&r<=R)
	{
		node[tr].sum+=add*(r-l+1);
		node[tr].val+=add;
		return;
	}
	pushdown(tr,r-l+1);
	int m=(l+r)>>1;
	if(L<=m)
		update(L,R,add,l,m,tr<<1);
	if(m<R)
		update(L,R,add,m+1,r,tr<<1|1);
	pushup(tr);
}
int main()
{
	int n,q;
	while(scanf("%d%d",&n,&q)!=EOF)
	{
		build(1,n,1);
		char s[3];
		while(q--)
		{
			scanf("%s",s);
			if(s[0]=='Q')
			{
				int a,b;
				scanf("%d%d",&a,&b);
				printf("%I64d\n",query(a,b,1,n,1));
			}
			else
				if(s[0]=='C')
				{
					int a,b;
					__int64 c;
					scanf("%d%d%I64d",&a,&b,&c);
					update(a,b,c,1,n,1);
				}
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值