POJ 3468 线段树区间更新求和模板

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 75854 Accepted: 23373
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9

15

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n, m;
struct node
{
    int l, r;
    long long sum, mark;
}s[300000];

void pushup(int k)
{
    s[k].sum = s[k<<1].sum + s[(k<<1)+1].sum;
}

void pushdown(int k, int d)
{
    if(s[k].mark)
    {
        s[k<<1].mark += s[k].mark;
        s[(k<<1)+1].mark += s[k].mark;
        s[k<<1].sum += s[k].mark * (d - (d >> 1));
        s[(k<<1)+1].sum += s[k].mark * (d >> 1);
        s[k].mark = 0;
    }
}

void init(int l, int r, int k)
{
    s[k].l = l, s[k].r = r, s[k].mark = 0;
    if(l == r)
    {
        scanf("%I64d", &s[k].sum);
        return;
    }
    int mid = (l + r) / 2;
    init(l, mid, k << 1);
    init(mid + 1, r, (k << 1) + 1);
    pushup(k);
}

void update(int l, int r, int c, int k)
{
    if(l <= s[k].l && s[k].r <= r)
    {
        s[k].mark += c;
        s[k].sum += c * (s[k].r - s[k].l + 1);
        return;
    }
    pushdown(k, s[k].r - s[k].l + 1);

    int mid = (s[k].l + s[k].r) >> 1;
    if(l <= mid) update(l, r, c, k << 1);
    if(r > mid) update(l, r, c, (k << 1) + 1);
    pushup(k);
}

long long query(int l, int r, int k)
{
    if(l <= s[k].l && s[k].r <= r) return s[k].sum;
    pushdown(k, s[k].r - s[k].l + 1);

    int mid = (s[k].l + s[k].r) / 2;
    long long res = 0;
    if(l <= mid) res += query(l, r, k << 1);
    if(r > mid) res += query(l, r, (k << 1) + 1);
    return res;
}

int main ()
{
    char cc;
    int a, b, c;

    scanf("%d%d", &n, &m);
    init(1, n, 1);

    for(int i = 0; i < m; i++)
    {
        scanf(" %c", &cc);
        if(cc == 'Q')
        {
            scanf("%d%d", &a, &b);
            printf("%I64d\n", query(a, b, 1));
        }
        else
        {
            scanf("%d%d%d", &a, &b, &c);
            update(a, b, c, 1);
        }
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值