HDOJ 题目2670 Girl Love Value(01背包)

Girl Love Value

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 748    Accepted Submission(s): 417


Problem Description
Love in college is a happy thing but always have so many pity boys or girls can not find it.
Now a chance is coming for lots of single boys. The Most beautiful and lovely and intelligent girl in HDU,named Kiki want to choose K single boys to travel Jolmo Lungma. You may ask one girls and K boys is not a interesting thing to K boys. But you may not know Kiki have a lot of friends which all are beautiful girl!!!!. Now you must be sure how wonderful things it is if you be choose by Kiki.



Problem is coming, n single boys want to go to travel with Kiki. But Kiki only choose K from them. Kiki every day will choose one single boy, so after K days the choosing will be end. Each boys have a Love value (Li) to Kiki, and also have a other value (Bi), if one boy can not be choose by Kiki his Love value will decrease Bi every day.
Kiki must choose K boys, so she want the total Love value maximum.
 

Input
The input contains multiple test cases.
First line give the integer n,K (1<=K<=n<=1000)
Second line give n integer Li (Li <= 100000).
Last line give n integer Bi.(Bi<=1000)
 

Output
Output only one integer about the maximum total Love value Kiki can get by choose K boys.
 

Sample Input
  
  
3 3 10 20 30 4 5 6 4 3 20 30 40 50 2 7 6 5
 

Sample Output
  
  
47 104
 

Author
yifenfei
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2668  2675  2671  2673  2672 
 


题目大意:有n个男孩,每个男孩对那个女孩都有一个爱慕值li,一个递减值bi,当女孩不选他时他的爱慕之减去没选他的天数乘递减值,每天只能选一个男孩,问选m个获得最大的m值是多少

ac代码

 

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
struct s
{
	int li,bi;
}a[1010];
int dp[1010];
int cmp(const void *a,const void *b)
{
	return (*(struct s *)b).bi-(*(struct s *)a).bi;
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i].li);
		}
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i].bi);
		}
		qsort(a,n,sizeof(a[0]),cmp);
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;i++)
		{
			for(j=m;j>=1;j--)
			{
				dp[j]=max(dp[j],dp[j-1]+a[i].li-(j-1)*a[i].bi);
			}
		}
		printf("%d\n",dp[m]);
	}
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值