HDU 2670 Girl Love Value



Girl Love Value

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 743    Accepted Submission(s): 412


Problem Description
Love in college is a happy thing but always have so many pity boys or girls can not find it.
Now a chance is coming for lots of single boys. The Most beautiful and lovely and intelligent girl in HDU,named Kiki want to choose K single boys to travel Jolmo Lungma. You may ask one girls and K boys is not a interesting thing to K boys. But you may not know Kiki have a lot of friends which all are beautiful girl!!!!. Now you must be sure how wonderful things it is if you be choose by Kiki.



Problem is coming, n single boys want to go to travel with Kiki. But Kiki only choose K from them. Kiki every day will choose one single boy, so after K days the choosing will be end. Each boys have a Love value (Li) to Kiki, and also have a other value (Bi), if one boy can not be choose by Kiki his Love value will decrease Bi every day.
Kiki must choose K boys, so she want the total Love value maximum.
 

Input
The input contains multiple test cases.
First line give the integer n,K (1<=K<=n<=1000)
Second line give n integer Li (Li <= 100000).
Last line give n integer Bi.(Bi<=1000)
 

Output
Output only one integer about the maximum total Love value Kiki can get by choose K boys.
 

Sample Input
  
  
3 3 10 20 30 4 5 6 4 3 20 30 40 50 2 7 6 5
 

Sample Output
  
  
47 104
 

Author
yifenfei
 
Source

题意:有n个男生追一个女生,每个男生有一个相应的爱慕值Vx(i),给定一个天数m,每天这个女生只能找一个女生,并且得到这个男生的爱慕值。每过一天,每个男生的爱慕值就会减少相应的 Vy(i);问女生如何选择,m天之后,才能得到最大的爱慕值。
咋看一眼是贪心的题目,每次都先选爱慕值最大的,和这个女生约会。。可是后来发现问题,要是天数很多的话,有些男生的爱慕值减少的很快,这样贪心就不好处理了,因为不清楚m天后的爱慕值,也不知道是先选减得多的还是爱慕值大的。
其实是01背包的变形。
讨论选不选第n-1个人。
假如选,爱慕值为dp[j]。假如不选,爱慕值为dp[j-1]+这个男生的爱慕值-(每天减少的爱慕值*天数)。
上代码
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include <math.h>
using namespace std;
struct node
{
    int value,ans;
};
bool cmp(node a,node b)
{
    return a.ans>b.ans;
}
/*---------------------------------------------*/
   //下面注释部分为贪心的错误解法。
/*---------------------------------------------*/

int main()
{
    node f[1005];
    int dp[1005];
    int n,day,i,j,love,Max;
    while(cin>>n>>day)
    {
        memset(dp,0,sizeof(dp));
        // love=0;
        for(i=0; i<n; i++)
            cin>>f[i].value;
        for(i=0; i<n; i++)
            cin>>f[i].ans;
        sort(f,f+n,cmp);
        /*
        while(day--)
        {
                love+=f[0].value;
                f[0].value=-100005;
                break;
            }

            for(i=0; i<n; i++)
            {
                if(f[i].value!=-100005)
                f[i].value-=f[i].ans;
            }
            sort(f,f+n,cmp);
        }
        */
        for(i=0; i<n; i++)
            for(j=day; j>0; j--)
            {
                dp[j]=max(dp[j],dp[j-1]+f[i].value-f[i].ans*(j-1));
            }
        // cout<<love<<endl;
        cout<<dp[day]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值