hdu Employment Planning(DP)

Employment Planning
Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project. 
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
   
   
3 4 5 6 10 9 11 0
 

Sample Output
   
   
199


状态转移方程:dp[i][j]=min(dp[i-1][k]+cost[i][j]);
1.dp[i][j]表示第i个月的j个人所用的最小费用, cost[i][j]是第i月j个人的花费
2.当k<=j时,第i个月请了人,所以cost[i][j]=j*salary+(j-k)*hire;
3.当k<j时,第i个月辞了人所以cost[i][j]=j*salary+(k-j)*fire;

因为给的是每个月最小需要的人数,所以for(该月最小人数--max_people)而不是for(1--该月的最小人数)

代码:
#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
#define min(a,b) (a<b?a:b)
const int INF=0x3f3f3f3f;
int dp[15][110];
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        int a[15];
        int x,y,z,i,j,k;
        scanf("%d%d%d",&x,&y,&z);
        int maxx=0;
        for(i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>maxx)
                maxx=a[i];
        }
        for(i=a[1]; i<=maxx; i++)//初始化第一个月
            dp[1][i]=i*(x+y);
        for(i=2; i<=n; i++)
        {
            for(j=a[i]; j<=maxx; j++)
            {
                int minx=INF;
                for(k=a[i-1]; k<=maxx; k++)
                {
                    if(k<=j)
                        minx=min(minx,dp[i-1][k]+x*(j-k)+y*j);
                    else
                        minx=min(minx,dp[i-1][k]+z*(k-j)+y*j);
                }
                dp[i][j]=minx;
            }
        }
        int ans=INF;
        for(i=a[n]; i<=maxx; i++)
            if(ans>dp[n][i])
                ans=dp[n][i];
        printf("%d\n",ans);
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值