UVA 题目10285 - Longest Run on a Snowboard(DP+记忆化搜索)

Michael likes snowboarding. That’s not very surprising, since snowboarding is really great. The bad
thing is that in order to gain speed, the area must slide downwards. Another disadvantage is that when
you’ve reached the bottom of the hill you have to walk up again or wait for the ski-lift.
Michael would like to know how long the longest run in an area is. That area is given by a grid of
numbers, defining the heights at those points. Look at this example:
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
One can slide down from one point to a connected other one if and only if the height decreases. One
point is connected to another if it’s at left, at right, above or below it. In the sample map, a possible
slide would be 24-17-16-1 (start at 24, end at 1). Of course if you would go 25-24-23-. . . -3-2-1, it would
be a much longer run. In fact, it’s the longest possible.
Input
The first line contains the number of test cases N. Each test case starts with a line containing the
name (it’s a single string), the number of rows R and the number of columns C. After that follow R
lines with C numbers each, defining the heights. R and C won’t be bigger than 100, N not bigger than
15 and the heights are always in the range from 0 to 100.
Output
For each test case, print a line containing the name of the area, a colon, a space and the length of the
longest run one can slide down in that area.
Sample Input
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
Sample Output
Feldberg: 7

Spiral: 25

题目大意:就是给你个矩阵,从矩阵中找个最长路,这个路上下个点要比这个点大,问这个最长度的长度。


ac代码

#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
int dp[110][110],map[110][110];
int dirx[4]={0,1,0,-1};
int diry[4]={1,0,-1,0};
int n,m;
int jud(int x,int y)
{
	if(x<1||x>n||y<1||y>m)
		return 0;
	return 1;
}
int dfs(int x,int y)
{
	if(dp[x][y])
		return dp[x][y];
	int team=0,i;
	int temp=0;
	for(i=0;i<4;i++)
	{
		int tx=x+dirx[i];
		int ty=y+diry[i];
		if(jud(tx,ty)&&map[x][y]<map[tx][ty])
		{
			temp=max(dfs(tx,ty),temp);
		}
	}
	dp[x][y]=temp+1;
	return dp[x][y];
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		char str[35];
		//	int n,m;
		scanf("%s%d%d",str,&n,&m);
		int i,j;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
				scanf("%d",&map[i][j]);
		}
		memset(dp,0,sizeof(dp));
		int ans=0;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				ans=max(ans,dfs(i,j));
			}
		}
		printf("%s: %d\n",str,ans);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值