uva 10285 Longest Run on a Snowboard 最长滑雪路

原题:
Michael likes snowboarding. That’s not very surprising, since snowboarding is really great. The bad
thing is that in order to gain speed, the area must slide downwards. Another disadvantage is that when
you’ve reached the bottom of the hill you have to walk up again or wait for the ski-lift.
Michael would like to know how long the longest run in an area is. That area is given by a grid of
numbers, defining the heights at those points. Look at this example:
1
2
3
4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
One can slide down from one point to a connected other one if and only if the height decreases. One
point is connected to another if it’s at left, at right, above or below it. In the sample map, a possible
slide would be 24-17-16-1 (start at 24, end at 1). Of course if you would go 25-24-23-…-3-2-1, it would
be a much longer run. In fact, it’s the longest possible.
Input
The first line contains the number of test cases N. Each test case starts with a line containing the
name (it’s a single string), the number of rows R and the number of columns C. After that follow R
lines with C numbers each, defining the heights. R and C won’t be bigger than 100, N not bigger than
15 and the heights are always in the range from 0 to 100.
Output
For each test case, print a line containing the name of the area, a colon, a space and the length of the
longest run one can slide down in that area.
Sample Input
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
Sample Output
Feldberg: 7
Spiral: 25
题目大意:
给你一个滑雪者的名字,然后给你一个二维数组。让你找这个二维数组里面的最长连续递减序列是多长?
就是poj那道滑雪的题目,不知道poj和uva上面这道题是谁山寨的谁…
思路见代码下方

暴力代码

#include<iostream>
#include<algorithm>
#include<map>
#include<string>
#include<cstring>
#include<sstream>
#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;
const int N=101;
int n,m;
int t,ans;
string name;
int dp[N][N];
int mou[N][N];
bool edge(int x,int y)
{
    if(x<1||x>m||y<1||y>n)
    return false;
    return true;
}
void dfs(int x,int y)
{
    if(edge(x+1,y)&&mou[x+1][y]<mou[x][y])
    {
        dp[x+1][y]=dp[x][y]+1;
        ans=max(ans,dp[x+1][y]);
        dfs(x+1,y);
    }
    if(edge(x-1,y)&&mou[x-1][y]<mou[x][y])
    {
        dp[x-1][y]=dp[x][y]+1;
        ans=max(ans,dp[x-1][y]);
        dfs(x-1,y);
    }
    if(edge(x,y+1)&&mou[x][y+1]<mou[x][y])
    {
        dp[x][y+1]=dp[x][y]+1;
        ans=max(ans,dp[x][y+1]);
        dfs(x,y+1);
    }
    if(edge(x,y-1)&&mou[x][y-1]<mou[x][y])
    {
        dp[x][y-1]=dp[x][y]+1;
        ans=max(ans,dp[x][y-1]);
        dfs(x,y-1);
    }
}
int main()
{
    ios::sync_with_stdio(false);
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        cin>>name;
        cin>>m>>n;
        ans=0;
        for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
        cin>>mou[i][j];
        for(int i=1;i<=m;i++)
        {
            for(int j=1;j<=n;j++)
            {
                dfs(i,j);
            }
        }
        cout<<name<<": "<<ans+1<<endl;
    }
    return 0;
}

记忆化搜索

#include<iostream>
#include<algorithm>
#include<map>
#include<string>
#include<cstring>
#include<sstream>
#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;
const int N=101;
int n,m;
int t,ans;
int dp[N][N];
int mou[N][N];
bool edge(int x,int y)
{
    if(x<1||x>m||y<1||y>n)
    return false;
    return true;
}
int dfs(int i,int j)
{
    int tmp=0;
    if(dp[i][j]>0)
        return dp[i][j];
    if(edge(i,j-1)&&mou[i][j]>mou[i][j-1])
        tmp=max(tmp,dfs(i,j-1));
    if(edge(i,j+1)&&mou[i][j]>mou[i][j+1])
        tmp=max(tmp,dfs(i,j+1));
    if (edge(i-1,j)&&mou[i][j]>mou[i-1][j])
        tmp=max(tmp,dfs(i-1,j));
    if(edge(i+1,j)&&mou[i][j]>mou[i+1][j])
        tmp=max(tmp,dfs(i+1,j));
    dp[i][j]=tmp+1;
    ans=max(ans,dp[i][j]);
    return dp[i][j];
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>m>>n)
    {
        ans=0;
        for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
            cin>>mou[i][j];
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=m;i++)
        {
            for(int j=1;j<=n;j++)
            {
                dfs(i,j);
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

思路:
首先根据经典的动态规划模型最长递增子序列可以得知这道题是动态规划,转移方程也非常好想。
dp[x][y]=max(dp[x-1][y],dp[x+1][y],dp[x][y+1],dp[x][y-1])+1;
这里使用记忆化搜索的方式,使得每次枚举一个滑雪的起点的时候能够找到一条路径,而不至于把全盘都dp一遍,节省时间。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值