UVA 题目10404 - Bachet's Game(DP+博弈)

Bachet’s game is probably
known to all but
probably not by this
name. Initially there
are n stones on the
table. There are two
players Stan and Ollie,
who move alternately.
Stan always
starts. The legal
moves consist in removing at least one but not more than k stones from the table. The winner is
the one to take the last stone.
Here we consider a variation of this game. The number of stones that can be removed in a single
move must be a member of a certain set of m numbers. Among the m numbers there is always 1 and
thus the game never stalls.
Input
The input consists of a number of lines. Each line describes one game by a sequence of positive numbers.
The first number is n ≤ 1000000 the number of stones on the table; the second number is m ≤ 10
giving the number of numbers that follow; the last m numbers on the line specify how many stones can
be removed from the table in a single move.
Output
For each line of input, output one line saying either ‘Stan wins’ or ‘Ollie wins’ assuming that both
of them play perfectly.
Sample Input
20 3 1 3 8
21 3 1 3 8
22 3 1 3 8
23 3 1 3 8
1000000 10 1 23 38 11 7 5 4 8 3 13
999996 10 1 23 38 11 7 5 4 8 3 13
Sample Output
Stan wins
Stan wins
Ollie wins
Stan wins
Stan wins

Ollie wins

题目大意:给你一堆石子,里边有n个,两个人取,给你一个m,后边m个数,表示取的可以取的石子数,其中一个肯定是1,先去完的赢

ac代码


dp值是-1时赢,0时表示输

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int dp[1000010],num[15];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int m;
		scanf("%d",&m);
		int i,j;
		for(i=0;i<m;i++)
		{
			scanf("%d",&num[i]);
		}
		sort(num,num+m);
		memset(dp,-1,sizeof(dp));
		dp[0]=0;
		for(i=1;i<=n;i++)
		{
			int flag=0;
			for(j=0;j<m&&num[j]<=i;j++)
			{
				if(dp[i-num[j]]==0)
				{
					flag=1;
					break;
				}
			}
			if(!flag)
				dp[i]=0;
		}
		if(dp[n]==-1)
		{
			printf("Stan wins\n");
		}
		else
			printf("Ollie wins\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值