UVA 题目10271 - Chopsticks(DP)

In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses
a set of three chopsticks – one pair, plus an EXTRA long chopstick to get some big food by piercing
it through the food. As you may guess, the length of the two shorter chopsticks should be as close as
possible, but the length of the extra one is not important, as long as it’s the longest. To make things
clearer, for the set of chopsticks with lengths A, B, C (A ≤ B ≤ C), (A − B)
2
is called the “badness”
of the set.
It’s December 2nd, Mr.L’s birthday! He invited K people to join his birthday party, and would like
to introduce his way of using chopsticks. So, he should prepare K + 8 sets of chopsticks(for himself,
his wife, his little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other
guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find
a way of composing the K + 8 sets, so that the total badness of all the sets is minimized.
Input
The first line in the input contains a single integer T, indicating the number of test cases (1 ≤ T ≤ 20).
Each test case begins with two integers K, N (0 ≤ K ≤ 1000, 3K + 24 ≤ N ≤ 5000), the number of
guests and the number of chopsticks.
There are N positive integers Li on the next line in non–decreasing order indicating the lengths of
the chopsticks (1 ≤ Li ≤ 32000).
Output
For each test case in the input, print a line containing the minimal total badness of all the sets.
Note: For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160
Sample Input
1
1 40
1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98
103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164
Sample Output

23

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define INF 0x3f3f3f3f3f3f3f
int dp[5010][1010];
int val[5010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int m,n;
        scanf("%d%d",&m,&n);
        m+=8;
        int i,j;
        memset(dp,INF,sizeof(dp));
        for(i=n;i>=1;i--)
        {
            dp[i][0]=0;
            scanf("%d",&val[i]);
        }
        for(i=3;i<=n;i++)
            for(j=1;j<=m;j++)
            {
                if(i>=j*3&&dp[i-2][j-1]!=INF)
                    dp[i][j]=min(dp[i-1][j],dp[i-2][j-1]+(val[i-1]-val[i])*(val[i-1]-val[i]));
            }
        printf("%d\n",dp[n][m]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值