HDOJ 题目3257 Hello World!(模拟)

Hello World!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 554    Accepted Submission(s): 208


Problem Description
Your task is to print ... er ... "Hello World" ... in a fantastic way -- using a beautiful font.

I've sent you a nice font for you to use, but I'm too busy to tell you how. Can you help yourself?
 

Input
The first line contains a single integer T (T <= 20), the number of test cases.
Each case begins with an integer C (1 <= C <= 80) in a single line, then each of the following C lines contains five two-digit numbers in hex (letters will be in uppercase). Don't ask me what they mean, I'm too busy...
 

Output
For each test case, print the case number in the first line, then followed by a blank line.
After that, print all T characters. Use a single blank column of spaces between two consecutive characters. Each line should have exactly 6C-1 character (again, don't ask me why).
Don't forget to print another blank line after the output of each test case.
 

Sample Input
  
  
2 11 7F 08 08 08 7F 38 54 54 54 18 00 41 7F 40 00 00 41 7F 40 00 38 44 44 44 38 00 00 00 00 00 3F 40 38 40 3F 38 44 44 44 38 7C 08 04 04 08 00 41 7F 40 00 38 44 44 48 7F 5 14 08 3E 08 14 04 02 01 02 04 40 40 40 40 40 04 02 01 02 04 14 08 3E 08 14
 

Sample Output
  
  
Case 1: # # ## ## # # ## # # # # # # # # # # # ### # # ### # # ### # ## # ## # ##### # # # # # # # # # # # ## # # # ## # # ##### # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # ### ### ### ### # # ### # ### #### Case 2: # # # # # # # # # # # # # # # # # # ### ### # # # # # # # # #####
 

Source
 

Recommend
wujianhua   |   We have carefully selected several similar problems for you:   3259  3251  3252  3253  3254 
 7F的二进制是1111111
所有第一列7个#。。
ac代码
152564452015-10-26 13:24:13Accepted32570MS1716K1631 BC++Who_you?

#include<stdio.h>
#include<string.h>
char str[10][500];
int n;
void init()
{
    int i,j;
    for(i=0;i<7;i++)
        for(j=0;j<6*n-1;j++)
            str[i][j]=' ';
}
int to10(char *s)
{
    int ans=0;
    int m=1;
    int i;
    for(i=1;i>=0;i--)
    {
        if(s[i]>='0'&&s[i]<='9')
        {
            ans+=(s[i]-'0')*m;
        }
        else
            ans+=(s[i]-'A'+10)*m;
        m*=16;
    }
    return ans;
}
int main()
{
    int cas,c=0;
    scanf("%d",&cas);
    while(cas--)
    {
    //    int n;
        scanf("%d",&n);
        init();
        char s[5];
        int i,j,num=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<5;j++)
            {
                scanf("%s",s);
                int res=to10(s);
                int deep=0;
                while(res)
                {
                    if(res%2==1)
                        str[deep][num]='#';
                    res/=2;
                    deep++;
                }
                num++;
            }
            num++;
        }
        printf("Case %d:\n\n",++c);
        for(i=0;i<7;i++)
        {
            for(j=0;j<6*n-1;j++)
            {
                printf("%c",str[i][j]);
            }
            printf("\n");
        }
        printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值