ZOJ Hello World!




Hello World!

Time Limit: 1 Second       Memory Limit: 32768 KB

Task

Your task is to print ... er ... "Hello World" ... in a fantastic way -- using a beautiful font.

I've sent you a nice font for you to use, but I'm too busy to tell you how. Can you help yourself?

Input

The first line contains a single integer T (T <= 20), the number of test cases. Each case begins with an integer C (1 <= C <= 80) in a single line, then each of the following C lines contains five two-digit numbers in hex (letters will be in uppercase). Don't ask me what they mean, I'm too busy...

Output

For each test case, print the case number in the first line, then followed by a blank line. After that, print all T characters. Use a single blank column of spaces between two consecutive characters. Each line should have exactly 6C-1 character (again, don't ask me why). Don't forget to print another blank line after the output of each test case.

Sample Input

2
11
7F 08 08 08 7F
38 54 54 54 18
00 41 7F 40 00
00 41 7F 40 00
38 44 44 44 38
00 00 00 00 00
3F 40 38 40 3F
38 44 44 44 38
7C 08 04 04 08
00 41 7F 40 00
38 44 44 48 7F
5
14 08 3E 08 14
04 02 01 02 04
40 40 40 40 40
04 02 01 02 04
14 08 3E 08 14

Sample Output

Case 1:

#   #        ##    ##               #   #              ##       #
#   #         #     #               #   #               #       #
#   #  ###    #     #    ###        #   #  ###  # ##    #    ## #
##### #   #   #     #   #   #       # # # #   # ##  #   #   #  ##
#   # #####   #     #   #   #       # # # #   # #       #   #   #
#   # #       #     #   #   #       # # # #   # #       #   #   #
#   #  ###   ###   ###   ###         # #   ###  #      ###   ####

Case 2:

        #           #        
  #    # #         # #    #  
# # # #   #       #   # # # #
 ###                     ### 
# # #                   # # #
  #                       #  
            #####            


思路:题目给的数据是16进制数,需要转化为二进制数,并且每一个数代表一列,一列为七个数,比如08二进制数为1 0 0 0 ;第二列中前三为空格,第四位#,后面自动默认为0,即为空格。注意每个字母后面加一列空格,每个字母有5列。其它的格式题目上面有要求。

#include<stdio.h>
#include<string.h>
int map[500][500],a,b;
void F(int x)
{
    while(x)
    {
        map[b++][a]=x%2;
        x=x/2;
    }
    a++;
}
int main()
{
    int t,k=0;
    scanf("%d",&t);
    while(t--)
    {
        memset(map,0,sizeof(map));
        int i,j,n,term;
        a=0,b=0;
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            for(j=0; j<5; j++)
            {
                scanf("%x",&term);
                b=0;
                F(term);
            }
        }
        printf("Case %d:\n\n",++k);
        for(i=0; i<7; i++)
        {
            for(j=0; j<5*n; j++)
                if((j+1)%5==0&&j!=(5*n-1))
                {
                    if(map[i][j])
                        printf("# ");
                    else printf("  ");
                }
                else if(map[i][j])
                    printf("#");
                else printf(" ");
            printf("\n");
        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值