FZUoj 题目2216 The Longest Straight*(二分)

Problem 2216 The Longest Straight

Accept: 22    Submit: 44
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

ZB is playing a card game where the goal is to make straights. Each card in the deck has a number between 1 and M(including 1 and M). A straight is a sequence of cards with consecutive values. Values do not wrap around, so 1 does not come after M. In addition to regular cards, the deck also contains jokers. Each joker can be used as any valid number (between 1 and M, including 1 and M).

You will be given N integers card[1] .. card[n] referring to the cards in your hand. Jokers are represented by zeros, and other cards are represented by their values. ZB wants to know the number of cards in the longest straight that can be formed using one or more cards from his hand.

 Input

The first line contains an integer T, meaning the number of the cases.

For each test case:

The first line there are two integers N and M in the first line (1 <= N, M <= 100000), and the second line contains N integers card[i] (0 <= card[i] <= M).

 Output

For each test case, output a single integer in a line -- the longest straight ZB can get.

 Sample Input

27 110 6 5 3 0 10 118 1000100 100 100 101 100 99 97 103

 Sample Output

53

 Source

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)
题目大意:一个n,m,后边n个数,0的个数代表鬼牌,龟牌什么都可以当,问选出的最大的连续的值得长度是多少
思路:暴力左端点二分右端点,,
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<math.h>
#include<algorithm>
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;
int vis[100010],num[100010];
void init(int m)
{
    int i;
    for(i=0;i<=m;i++)
        vis[i]=0;
}
int bseach_l(int l,int r,int val)
{
    int ans=r;
    int tl=l;
    while(l<=r)
    {
        int mid=(l+r)>>1;
        if(num[mid]-num[tl]>val)
        {
           // ans=mid;
            //l=mid+1;
            r=mid-1;
        }
        else
            l=mid+1;
    }
    return r;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int i;
        int cnt=0;
        memset(vis,0,sizeof(vis));
        for(i=0;i<n;i++)
        {
            int x;
            scanf("%d",&x);
            if(x==0)
            {
                cnt++;
                continue;
            }
            vis[x]=1;
        }
        int ans=0,tc=cnt,pt;
        memset(num,0,sizeof(num));
        for(i=1;i<=m;i++)
        {
            if(vis[i])
                num[i]=num[i-1];
            else
                num[i]=num[i-1]+1;
        }
        for(i=0;i<=m;i++)
        {
            int temp=bseach_l(i,m,cnt);
            ans=max(temp-i,ans);
        }
        printf("%d\n",ans);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值