fzu 2216 The Longest Straight

Problem 2216 The Longest Straight

Accept: 178    Submit: 536
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 ProblemDescription

ZB is playing a card game where the goal is to makestraights. Each card in the deck has a number between 1 and M(including 1 andM). A straight is a sequence of cards with consecutive values. Values do notwrap around, so 1 does not come after M. In addition to regular cards, the deckalso contains jokers. Each joker can be used as any valid number (between 1 andM, including 1 and M).

You will be given N integers card[1] .. card[n] referringto the cards in your hand. Jokers are represented by zeros, and other cards arerepresented by their values. ZB wants to know the number of cards in thelongest straight that can be formed using one or more cards from his hand.

 Input

The first line contains an integer T, meaning the numberof the cases.

For each test case:

The first line there are two integers N and M in thefirst line (1 <= N, M <= 100000), and the second line contains N integerscard[i] (0 <= card[i] <= M).

 Output

For each test case, output a single integer in a line --the longest straight ZB can get.

 Sample Input

2

7 11

0 6 5 3 0 10 11

8 1000

100 100 100 101 100 99 97 103

 SampleOutput

5

3

 Source

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)

 

 一道令我伤心了好久的题目,省赛那时我非常弱鸡,这题没做出来,与奖失之交臂。。。

题目大意:给你一些牌(0表示鬼牌,可以代替任何牌)求可以组成的顺子的最大长度。(斗地主的顺子知道吧)

思路:二分+枚举,每次枚举左端点,求这个左端点能组成的最大长度。


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn = 100005;
int n, m, zero;
int num[maxn];			//num表示从1到i成为顺子所需鬼牌的个数
int card[maxn];

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		zero = 0;
		memset(num, 0, sizeof(num));
		memset(card, 0, sizeof(card));
		scanf("%d%d", &n, &m);
		for (int i = 0; i < n; i++)
		{
			int x;
			scanf("%d", &x);
			if (!x)
				zero++;
			else
				card[x] = 1;
		}

		for (int i = 1; i <= m; i++)
			num[i] = num[i - 1] + (1-card[i]);

		int ans = 0;
		for (int i = 1; i <= m; i++)
		{
			int k = upper_bound(num + i, num + m + 1, zero + num[i-1]) - (num + i);
			ans = max(ans, k);
		}
		printf("%d\n", ans);
	}
	return 0;
}


当然,也有更快的做法,时间复制度为O(N)

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn = 1e5 + 5;
int card[maxn], num[maxn], pos[maxn];
int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		memset(pos, 0, sizeof(pos));
		memset(num, 0, sizeof(num));
		memset(card, 0, sizeof(card));
		int m, n, zero = 0;
		scanf("%d%d", &m, &n);
		for (int i = 1; i <= m; i++)
		{
			int x;
			scanf("%d", &x);
			if (x == 0) zero++;
			else
				card[x] = 1;
		}
		int ans = 0,k;
		pos[0] = 1;
		for (int i = 1; i <= n; i++)
		{
			num[i] = num[i - 1] + (1 - card[i]);
			if (!card[i])
				pos[num[i]] = i;
			k = num[i] - zero;
			if (k <= 0) 
			{
				ans = i;
				continue;
			}
			ans = max(ans, i - pos[k]);
		}
		printf("%d\n", ans);
	}
	return 0;
}

/*

22
7 11
0 6 5 3 0 10 11
8 1000
100 100 100 101 100 99 97 103
3 5
1 2 3
3 2
1 2 3
3 5
1 2 0
3 5
2 3 4
3 5
2 0 4


*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值