HDOJ 题目5067 Harry And Dig Machine(状压dp,TSP)

Harry And Dig Machine

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 806    Accepted Submission(s): 315


Problem Description
  As we all know, Harry Porter learns magic at Hogwarts School. However, learning magical knowledge alone is insufficient to become a great magician. Sometimes, Harry also has to gain knowledge from other certain subjects, such as language, mathematics, English, and even algorithm. 
  Dumbledore, the headmaster of Hogwarts, is planning to construct a new teaching building in his school. The area he selects can be considered as an n*m grid, some (but no more than ten) cells of which might contain stones. We should remove the stones there in order to save place for the teaching building. However, the stones might be useful, so we just move them to the top-left cell. Taking it into account that Harry learned how to operate dig machine in Lanxiang School several years ago, Dumbledore decides to let him do this job and wants it done as quickly as possible. Harry needs one unit time to move his dig machine from one cell to the adjacent one. Yet skilled as he is, it takes no time for him to move stones into or out of the dig machine, which is big enough to carry infinite stones. Given Harry and his dig machine at the top-left cell in the beginning, if he wants to optimize his work, what is the minimal time Harry needs to finish it?
 

Input
They are sever test cases, you should process to the end of file.
For each test case, there are two integers n and m. (1n,m50) .
The next n line, each line contains m integer. The j-th number of  ith  line a[i][j] means there are a[i][j] stones on the  jth  cell of the  ith  line.(  0a[i][j]100  , and no more than 10 of a[i][j] will be positive integer).
 

Output
For each test case, just output one line that contains an integer indicate the minimal time that Harry can finish his job.
 

Sample Input
  
  
3 3 0 0 0 0 100 0 0 0 0 2 2 1 1 1 1
 

Sample Output
  
  
4 4
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:   5604  5603  5602  5601  5600 
 
题目大意:一个矩阵每走一个相邻的格子消耗一个时间,每个矩阵里边大于0的地方都是石头,他要从左上角走把所有石头都走一遍,然后再回到左上角
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#define INF 0x3f3f3f3f
#define mod 1000000007
using namespace std;
int dp[(1<<10)+10][15];
int map[110][110],dis[110][110];
int id[110][110];
struct s
{
    int x,y;
}a[150];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int i,j,k;
        memset(id,0,sizeof(id));
       // memset(dis,INF,sizeof(dis));
        int cc=0;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                scanf("%d",&map[i][j]);
               if(map[i][j]>0)
                {
                    a[cc].x=i;
                    a[cc].y=j;
                    id[i][j]=cc;
                    cc++;
                }
            }
        }
        for(i=0;i<cc;i++)
        {
            for(j=0;j<cc;j++)
            {
                dis[i][j]=abs(a[i].x-a[j].x)+abs(a[i].y-a[j].y);
            }
        }
        memset(dp,INF,sizeof(dp));
        for(i=0;i<cc;i++)
        {
            dp[1<<i][i]=abs(1-a[i].x)+abs(1-a[i].y);
        }
        int rt=(1<<cc)-1;
        for(i=1;i<=rt;i++)
        {
            for(j=0;j<cc;j++)
            {
                if(dp[i][j]==INF)
                    continue;
                for(k=0;k<cc;k++)
                {
                    if(dis[j][k]==INF||(i&(1<<k)))
                        continue;
                    int st=i|(1<<k);
                    dp[st][k]=min(dp[st][k],dp[i][j]+dis[j][k]);
                }
            }
        }
        int ans=INF;
        for(i=0;i<cc;i++)
        {
            if(ans>dp[rt][i]+abs(1-a[i].x)+abs(1-a[i].y))
                ans=dp[rt][i]+abs(1-a[i].x)+abs(1-a[i].y);
        }
        if(ans==INF)
            ans=0;
        printf("%d\n",ans);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值