java蝴蝶效应

Problem Description

蝴蝶效应是气象学家洛伦兹1963年提出来的。其大意为:一只南美洲亚马孙河流域热带雨林中的蝴蝶,偶尔扇动几下翅膀,可能在两周后引起美国德克萨斯引起一场龙卷风。其原因在于:蝴蝶翅膀的运动,导致其身边的空气系统发生变化,并引起微弱气流的产生,而微弱气流的产生又会引起它四周空气或其他系统产生相应的变化,由此引起连锁反应,最终导致其他系统的极大变化。此效应说明,事物发展的结果,对初始条件具有极为敏感的依赖性,初始条件的极小偏差,将会引起结果的极大差异。

我们将问题简化为方程 f(x) = (a*f(max(0,x-b)) + c*f(max(0,x-d)))%1000000007。

现在给出不同的f(0)和n以及参数a,b,c,d,计算出f(n)。

Input

多组输入。

对于每组数据,有六个个整数n,f0(1 <= n <= 10000,1 <= f0 <= 10000)a,b,c,d(1 <= a,b,c,d <= 10000)

Output

对于每组数据输出f(n)。

Example Input
1 2 3 4 5 6
Example Output
16
import java.util.Scanner;  
public class Main 
{  
    static int  a, b, c, d;  
    static long f[] = new long[110000];  
    final static long mod = 1000000007;       
    public static void main(String[] args) 
    {  
        long p;  
        int n;  
        Scanner cin = new Scanner(System.in);  
        while(cin.hasNext())
        {  
            for(int i = 0; i <= 100010; i++)  
            {
             f[i] = 0;  
            }
            n = cin.nextInt();  
            p = cin.nextLong();  
            a = cin.nextInt();  
            b = cin.nextInt();  
            c = cin.nextInt();  
            d = cin.nextInt();  
            f[0] = p;  
            long x = fou(n);  
            System.out.println(x);    
        }  
    }  
      public static long fou(int x)
      {  
       if(x <= 0)  
       {
        return f[0];  
       }
        if(f[x] != 0)  
        {
         return f[x];  
        }
        f[x] = (a * fou(x - b) + c * fou( x - d)) % mod;  
        {
         return f[x];  
        }
   }  
  
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值