PAT 乙级 1028. 人口普查(20)

1028. 人口普查(20)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John


  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  使用高级编辑器

     1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    #include <cstdio>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    struct people
    {
        char name[8];
        int td;
    } p[100001];
    int a[]={0,31,28,31,30,31,30,31,31,30,31,30,31};
    int cal_month(int q,int d)//计算从01.01日到q月d日是多少天
    {
        int i;
        int ans=0;
        for(i=1;i<q;i++)
        ans+=a[i];
        ans+=d;
        return ans;
    }
     
    int cmp(people A,people B) {
        return A.td > B.td;
    }
    int day_diff(int year_start, int month_start, int day_start, int year_end, int month_end, int day_end) //计算从某年某月某日到某年某月某日的天数
    {
        int y2, d2,y1, d1;
        int count1=0;
        int y=year_start;
        count1=y/4-y/100+y/400;//从公元元年到y年的因为闰年多出的天数
    y1=365*y+count1;
    d1=cal_month(month_start,day_start)+y1;//总天数
    int yy=year_end;
    count1=yy/4-yy/100+yy/400;
    y2=365*yy+count1;
    d2=cal_month( month_end,day_end)+y2;
     
        return (d2 - d1);//相差的天数
    }
    int main() {
        int n, count = 0, y, m, d;
        char name[8];
        scanf("%d", &n);
        int limt=day_diff(1814, 9, 6, 2014, 9, 6);//两百年的天数
        for (int i = 0; i < n; i++) {
            scanf("%s %d/%d/%d", name, &y, &m, &d);
            int t = day_diff(y, m, d, 2014, 9, 6);//计算相差的天数
            if (t >= 0 && t<=limt) {//满足条件
                strcpy(p[count].name, name);
                p[count++].td = t;
            }
        }
        sort(p, p + count, cmp);//排序
        if(count==0)printf("0");
        else
        printf("%d %s %s", count, p[0].name, p[count - 1].name);
        return 0;
    }
     

    • 0
      点赞
    • 0
      收藏
      觉得还不错? 一键收藏
    • 0
      评论
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值