poj1723 中位数的应用

N soldiers of the land Gridland are randomly scattered around the country.
A position in Gridland is given by a pair (x,y) of integer coordinates.
Soldiers can move - in one move, one soldier can go one unit up, down, left or right
(hence, he can change either his x or his y coordinate by 1 or -1).
The soldiers want to get into a horizontal line next to each other
(so that their final positions are (x,y), (x+1,y), ..., (x+N-1,y), for some x and y).
Integers x and y, as well as the final order of soldiers along the horizontal line is
arbitrary.
The goal is to minimise the total number of moves of all the soldiers that takes them
into such configuration.
Two or more soldiers must never occupy the same position at the same time.
Input
The first line of the input contains the integer N, 1 <= N <= 10000, the number of
soldiers.
The following N lines of the input contain initial positions of the soldiers :
for each i, 1 <= i <= N, the (i+1) st line of the input file contains a pair of
integers x[i] and y[i] separated by a single blank character, representing the coordinates
of the ith soldier, -10000 <= x[i],y[i] <= 10000.
Output
The first and the only line of the output should contain the minimum total number of moves
that takes the soldiers into a horizontal line next to each other.
Sample Input
5
1 2
2 2
1 3
3 -2
3 3
Sample Output
8
题意:已知有n个士兵,以及他们的坐标(x,y),最后他们必须移动到同一条水平线上。
(目标设为(k,y),(k+1,y)...(k+n-1,y))
每个士兵只能向上下左右移动,求最少的总移动步数。

思路:分别对x,y分析。
y坐标:要想使移动步数最少,即|y-y0|+|y-y1|+...+|y-y[n-1]|的和最小,只需y取中位数即可,得到结果为
最后一项减第一项,然后分别后移前移,进行计算。
x坐标:设x坐标最后为k,k+1,k+2,...k+n-1. 要想使移动步数最少,则|x0-k|+|x1-1-k|+|x2-2-k|+...+|x[n-1]-(n-1)-k|
的和最小,即k取(x0,x1-1x2-2,x3-3,...x[n-1]-(n-1)的中位数即可),计算同y。


#include <cstdio>
#include <algorithm>
#define N 10005
using namespace std;

int x[N], y[N];

int main()
{
	long long int ans;
	int n;
	while (scanf("%d", &n) != EOF)
	{
		ans = 0;
		for (int i = 0; i < n; i++)
			scanf("%d%d", &x[i], &y[i]);
		sort(x, x + n);
		sort(y, y + n);

		for (int i = 0; i < n; i++)
			x[i] -= i;
		
		sort(x, x + n);

		for (int i = 0, j = n - 1; i < j; i++, j--)
			ans += y[j] - y[i] + x[j] - x[i];

		printf("%lld\n", ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值