查找元素

D - The Suspects
Time Limit:1000MS     Memory Limit:20000KB     64bit IO Format:%I64d & %I64u

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
#include <stdio.h>
#include <stdlib.h>
 
/*
num[]存储节点所在集合元素的个数
father[]存储节点的父节点
*/
int num[30001], father[30001];
 
/* 初始化集合 */
void Make_Set(int x)
{
	father[x] = -1;
	num[x] = 1;
}
 
/* 查找x元素所在的集合,返回根节点 */
int Find_Set(int x)
{
	/* 保存待查找值x */
	
	/* 找到根节点r */
	while (father[x] != -1)
	{
		x = father[x];
	}
	/* 压缩路径,将路径上所有r的子孙都连接到r上 */
	
	return x;
}
 
/* 合并a,b所在的集合 */
void Union_Set(int a, int b)
{
	a = Find_Set(a);
	b = Find_Set(b);
	/* 如果两个元素在同一个集合则不需要合并 */
	if (a == b) return;
	/* 将小集合合并到大集合中,更新集合个数 */
	if (num[a] <= num[b])
	{
		father[a] = b;
		num[b] += num[a];
	}
	else
	{
		father[b] = a;
		num[a] += num[b];
	}
}
 
int main()
{
	int a, b, n, m, t;
	int i, j;
	while (1)
	{
		scanf("%d%d", &n, &m);
		if (n + m == 0) break;
		for (i = 0; i < n; i++)
		{
			Make_Set(i);	
		}
		for (i = 0; i < m; i++)
		{
			scanf("%d", &t);
			scanf("%d", &a);
			for (j = 1; j < t; j++)
			{
				scanf("%d", &b);
				Union_Set(a, b);
			}
		}
		printf("%d\n", num[Find_Set(0)]);
	}
	return 0;
}


`vector`是C++标准模板库(STL)中的一个动态数组容器,它可以在运行时动态改变大小。在`vector`中查找元素可以使用多种方法,具体取决于你想要查找的是第一个匹配元素,还是所有匹配元素,以及是否需要遍历整个容器或者利用`vector`的有序性质。以下是一些常见的查找方法: 1. `std::find`:适用于顺序查找,如果`vector`不是有序的,使用`std::find`是查找单个元素的常规方法。它返回一个指向找到元素的迭代器,如果没有找到则返回`vector.end()`。 2. `std::find_if`:允许使用自定义的谓词函数,适用于在`vector`中查找满足特定条件的第一个元素。 3. `std::binary_search`:需要`vector`是预先排序好的。这是一个二分查找算法,非常高效,但如果`vector`未排序,则不能保证结果的正确性。 4. `std::lower_bound`和`std::upper_bound`:这两个函数通常用于有序`vector`中查找某个值的范围,`lower_bound`返回第一个不小于(即大于或等于)给定值的元素的迭代器,而`upper_bound`返回第一个大于给定值的元素的迭代器。 使用`std::find`的示例代码如下: ```cpp #include <vector> #include <algorithm> // for std::find int main() { std::vector<int> vec = {1, 2, 3, 4, 5}; int value_to_find = 3; auto it = std::find(vec.begin(), vec.end(), value_to_find); if (it != vec.end()) { // 找到了元素 } else { // 没有找到元素 } return 0; } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值