网络流EK算法

F - Flow Problem
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input

The first line of input contains an integer T, denoting the number of test cases. 
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000) 
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output

For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input

     
     
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output

     
     
Case 1: 1 Case 2: 2
 :
网络最大流,是用来求从源点到汇点的最大流量,这里的汇点一般为出度为0的点,同理源点为入度为0的点,EK算法经典之处在于,利用BFS不断找出源点到汇点的一条路,利用增光路进行删减流量,利用增光路的特性,简化过程,bfs的作用只有两个,1是传回前驱点,2是找出局部最大流。
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define INF 0x7fffffff 
queue<int>Q;
int map[20][20],pre[20];
int bfs(int s,int e){
	int flow[20];
	for(int i=1;i<=e;i++)pre[i] = -1;
	pre[1] = 0;
	while(!Q.empty())Q.pop();
	flow[s] = INF;
	Q.push(s);
	while(!Q.empty()){
		int a= Q.front();
		Q.pop();
		if(a == e)break;
		for(int i=1;i<=e;i++){
			if(map[a][i]>0&&pre[i] == -1){
				Q.push(i);
				flow[i] = min(map[a][i],flow[a]);
				pre[i] = a;
			}
		}
	}
	
	if(pre[e] == -1)return -1;
	else return flow[e];
}
int main(){
	int t,m,n,o=0;
	scanf("%d",&t);
	while(t--){
		int a,b,c;
		int s = 0;
		o++;
		memset(map,0,sizeof(map));
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++){		
		scanf("%d%d%d",&a,&b,&c);
		if(a!=b)map[a][b]+=c;
		}
		int flow;
        while((flow = bfs(1,n))!=-1){
        	s+=flow;
        	int k = n;
        	while(k!=1){
	        	int last = pre[k];
	        	map[last][k] -= flow;
	        	map[k][last] += flow;
	        	k = last;
	        }
        }
		printf("Case %d: %d\n",o,s);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值