hdu1010

http://acm.hdu.edu.cn/showproblem.php?pid=1010


Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 89573    Accepted Submission(s): 24362


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 
有一条狗,在一个迷宫里有一根骨头,这只狗很馋,进入迷宫,叼走了骨头,当他叼走骨头时,他每走一步,走过的路开始开始下陷,狗每走一步用时一秒,他可以选择上下左右走,但是“X"表示墙,不可以过,”D"表示门,问这只狗能不能在t时刻走到门口

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
using namespace std;
int sx,sy,gx,gy;
int T,t,flag;
char  map[10][10];
int N,M;
int d[4][2]= { {1,0},{0,1},{0,-1},{-1,0} };
void bfs(int x,int y,int t)
{
    if(flag==1)
        return;
    if(t<abs(x-gx)-abs(y-gy)||(t-abs(x-gx)-abs(y-gy))%2==1)
        return;
    if(t==0)
    {
        if(x==gx&&y==gy)
        {
            flag=1;
            return;
        }
        else
            return;
    }
    for(int i=0; i<4; i++)
    {
        int nx=d[i][0]+x;
        int ny=d[i][1]+y;
        if(nx>=0&&ny>=0&&nx<N&&ny<M&&(map[nx][ny]=='.'||map[nx][ny]=='D'))
        {
            map[nx][ny]='X';
            bfs(nx,ny,t-1);
            map[nx][ny]='.';
        }
    }
    return;

}
int main()
{
    while(~scanf("%d%d%d",&N,&M,&T))
    {
        if(N==0&&M==0&&T==0)
            break;
        for(int i=0; i<N; i++)
        {
            scanf("%s",map[i]);
            for(int j=0; j<M; j++)
            {
                if(map[i][j]=='S')
                {
                    sx=i,sy=j;
                }
                if(map[i][j]=='D')
                {
                    gx=i,gy=j;
                }
            }
        }
        flag=0;
        t=T;
        bfs(sx,sy,t);
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");

    }
    //cout << "Hello world!" << endl;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值