poj1426

http://poj.org/problem?id=1426


Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22375 Accepted: 9190 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
题意;  给定一个数n,求用0,1组成的十进制数m,m将n整除


#include <iostream>
#include <stdio.h>
///联想大数除法,能否除尽的问题  156589465498554689564154611656/56653能够除尽
using namespace std;
int mod[524286];
int main()
{
    int n,i;
    while(cin>>n)
     {
         if(n==0)
            break;
         mod[1]=1%n;
         for( i=2;mod[i-1]!=0;i++)
            mod[i]=(mod[i/2]*10+i%2)%n;
         i--;
         int op=0;
         while(i)
         {
             mod[op++]=i%2;
             i=i/2;
         }
         for(int j=op-1;j>=0;j--)
            cout<<mod[j];
         cout<<endl;
     }
    ///cout << "Hello world!" << endl;
    return 0;
}
///对大数取余,124/4 : 1%2=1; 1*10+2%4=0;得,已经 等于 0了,说明124能
///整除2 ,,
///mod[]数组 存放余数,最高位放1,下一位放0||1,(i%2,当i为 奇数,下一位为1
///,当i为偶数,下一位 取0),bfs  两个入口的分叉,mod[i/2]为i的上一级入口
///最后一位 决定路线


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值