hdu3117

http://acm.hdu.edu.cn/showproblem.php?pid=3117


Fibonacci Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2201    Accepted Submission(s): 886


Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.

What is the numerical value of the nth Fibonacci number?
 

Input
For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”). 

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
 

Sample Input
  
  
0 1 2 3 4 5 35 36 37 38 39 40 64 65
 

Sample Output
  
  
0 1 1 2 3 5 9227465 14930352 24157817 39088169 63245986 1023...4155 1061...7723 1716...7565
 
#include <iostream>
#include <math.h>
#include <stdio.h>
using namespace std;
int fib[50];
int const mod=10000;
struct ac
{
    long long  m[2][2];
};
void get()
{
    fib[0]=0;
    fib[1]=1;
    for(int i=2; i<40; i++)
        fib[i]=fib[i-1]+fib[i-2];
}
ac ju(ac a,ac b)
{
          ac c;
            for(int i=0; i<2; i++)
            {
                for(int j=0; j<2; j++)
                {
                    c.m[i][j]=0;
                    for(int k=0; k<2; k++)
                        c.m[i][j]+=(a.m[i][k]*b.m[k][j])%mod;
                    c.m[i][j]%=mod;
                }
            }
  return c;
}
ac Anci(long long n)
{
    ac  a={0,1,
        1,1 };
    ac  b={1,0,
          0,1  };
    while(n>=1)
    {
        if(n&1)
        b=ju(a,b);
        n>>=1;
        a=ju(a,a);
    }
    return b;
}
int main()
{
    double temp;
    long long n;
    get();
    while(cin>>n)
    {
        if(n<40)
            cout<<fib[n]<<endl;
        else
        {
            temp= (double )(n*1.0*log10( (1+sqrt(5.0))/2.0)+log10(1.0/sqrt(5.0)));
            cout<<(int)( pow(10,temp-int(temp)+3));
            cout<<"...";
            ac   d=Anci(n);
            int ans=d.m[0][1];
            printf("%04d\n",ans);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值