2016多校第6场1010 --hdu5802 搜索-剪枝+贪心

Windows 10

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 754    Accepted Submission(s): 221


Problem Description
Long long ago, there was an old monk living on the top of a mountain. Recently, our old monk found the operating system of his computer was updating to windows 10 automatically and he even can't just stop it !!
With a peaceful heart, the old monk gradually accepted this reality because his favorite comic LoveLive doesn't depend on the OS. Today, like the past day, he opens bilibili and wants to watch it again. But he observes that the voice of his computer can be represented as dB and always be integer. 
Because he is old, he always needs 1 second to press a button. He found that if he wants to take up the voice, he only can add 1 dB in each second by pressing the up button. But when he wants to take down the voice, he can press the down button, and if the last second he presses the down button and the voice decrease x dB, then in this second, it will decrease 2 * x dB. But if the last second he chooses to have a rest or press the up button, in this second he can only decrease the voice by 1 dB.
Now, he wonders the minimal seconds he should take to adjust the voice from p dB to q dB. Please be careful, because of some strange reasons, the voice of his computer can larger than any dB but can't be less than 0 dB.
 

Input
First line contains a number  T  ( 1T300000 ),cases number.
Next T line,each line contains two numbers  p  and  q   (0p,q109)
 

Output
The minimal seconds he should take
 

Sample Input
  
  
2 1 5 7 3
 

Sample Output
  
  
4

4

题意:有两个个音量调节键,向上调每次音量加一,向下调,每次音量加 2^x,x从0开始,每按一次,花费1秒,如果向下调的过程中突然向上调,x重新置为0,音量加一,花费1秒,如果向下调的过程中停顿1 秒,x也会置0

思路:

比较直观的看法是使劲往下降,然后升回来

或者使劲往下降然后停顿然后再使劲往下降。。。

于是就能将问题变成一个子问题,然后dfs就好

需要注意的是由于按up键也可以打断连续向下的功效

所以应该记录停顿了几次,以后向上的时候用停顿补回来,就是如果一定需要向上调,就在该停顿是向上调,这样既保证向上调,又能使x置0

ac代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
typedef long long ll;
ll sum[50];
ll ans,a,b;
void init()
{
    sum[0]=0;
    for(ll i=1; i<=33; i++)
        sum[i]=(1<<i)-1;
}
ll dfs(ll x,ll step,ll stop )
{
    if(x==b)return step;///x 当前位置,等于b 时退出当前栈
    int k=0;
    while(x-sum[k]>b)///找到k值,向下跳k步后  使得当前位置小于等于b位置
        k++;
    if(x-sum[k]==b)
        return step+k;///刚好跳到b位置
    ll up =b-max((ll)0,x-sum[k]);///x-sum[k] 在b下面 --> 向上跳的步数并且最多走到0位置
    ll res=k+max((ll)0,up-stop);///加入走了k步,再往上走,总共 k+up-stop 步
    ///up - stop ,往上走就不需要停顿了,up的步数比停顿的多 用up 顶替停顿,
    // cout<<"up= "<<up<<" stop= "<<stop<<" step= "<<step<<" res= "<<res<<endl;
    return min(step+res,dfs(x-sum[k-1],step+k,stop+1));///取现在向上反 和继续向下跑的最小的那个
}
int main()
{
    init();
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld",&a,&b);
        if(a<=b)
        {
            printf("%lld\n",b-a);
            continue;
        }
        else
            printf("%lld\n",dfs(a,0,0));
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值