HDU5802-Windows 10

75 篇文章 0 订阅
22 篇文章 0 订阅

Windows 10

                                                                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                            Total Submission(s): 2305    Accepted Submission(s): 694


Problem Description
Long long ago, there was an old monk living on the top of a mountain. Recently, our old monk found the operating system of his computer was updating to windows 10 automatically and he even can't just stop it !!
With a peaceful heart, the old monk gradually accepted this reality because his favorite comic LoveLive doesn't depend on the OS. Today, like the past day, he opens bilibili and wants to watch it again. But he observes that the voice of his computer can be represented as dB and always be integer. 
Because he is old, he always needs 1 second to press a button. He found that if he wants to take up the voice, he only can add 1 dB in each second by pressing the up button. But when he wants to take down the voice, he can press the down button, and if the last second he presses the down button and the voice decrease x dB, then in this second, it will decrease 2 * x dB. But if the last second he chooses to have a rest or press the up button, in this second he can only decrease the voice by 1 dB.
Now, he wonders the minimal seconds he should take to adjust the voice from p dB to q dB. Please be careful, because of some strange reasons, the voice of his computer can larger than any dB but can't be less than 0 dB.
 

Input
First line contains a number  T  ( 1T300000 ),cases number.
Next T line,each line contains two numbers  p  and  q   (0p,q109)
 

Output
The minimal seconds he should take
 

Sample Input
  
  
2 1 5 7 3
 

Sample Output
  
  
4 4
 

Author
UESTC
 

Source
 

Recommend
wange2014
 

题意:调节音量p到q,上升音量每秒只能上升1,下降音量每秒为2*x,x为上一次下降的音量,如果下降时休息或者上升音量则x置为1,音量最低为0,问最少需要调节几次

解题思路:贪心的去选,每次下降到终点上的最近一点,或者终点下的一点,取一个最小值


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

LL sum[50], p, q;

void init()
{
	LL k = 1;
	sum[1] = 1;
	for (int i = 2; i <= 32; i++)
	{
		k = k * 2;
		sum[i] = sum[i - 1] + k;
	}
}

LL dfs(LL x, int step, int stop)
{
	int k = 1;
	while (x - sum[k] > q) k++;
	if (x - sum[k] == q)	return step + k;
	LL up = q - max((LL)0, x - sum[k]);
	LL tmp = k + max((LL)0, up - stop);
	return min(step + tmp, dfs(x - sum[k - 1], step + k, stop + 1));
}

int main()
{
	int t;
	scanf("%d", &t);
	init();
	while (t--)
	{
		scanf("%lld%lld", &p, &q);
		if (q >= p) { printf("%lld\n", q - p); continue; }
		printf("%lld\n", dfs(p, 0, 0));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值