poj3436--网络流

ACM Computer Factory
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7023 Accepted: 2484 Special Judge

Description

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,P Di,1 Di,2...Di,P, where Qi specifies performance, Si,j— input specification for part jDi,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0

Hint

Bold texts appearing in the sample sections are informative and do not form part of the actual data.


题意:一个机器由n个零件组成,但是n个零件的装配是有先后顺序的,每个零件有p部分,用G1 G2 。。。Gp 表示,如果要装Mi 零件,当前的半成品机器必须满足Mi  的p个部分属性,Gi 为0 表示Gi 部分 不 ! 需!要!!!,为1 表示  必! 须 ! 要 !!!,为2表示可以要可以不要,装上Mi 零件后 当前 半 成品机器会得到Mi 的p 个部分的属性,比如第一组样例:

                      需要              得到属性

  3 4  p1 p2 p3   p1 p2 p3
M1 15  0   0  0   0  1  0
M2 10  0   0  0   0  1  1
M3 30  0   1  2   1  1  1
M4 3   0   2  1   1  1  1
  
M1 3个属性全为0,直接装到机器上,接下来得到3个属性是 G1=0 G2=1  G3=0 ,表示要想拼接下一个零件,下一个零件
必须满足G2=1,G1 G3 可以可以是0或者2,所以下一个零件选择M3 ;

知道这些后,我们就可以来一个二重循环,把可以接到一起的零件全部接到一起,建立一条边,权值为两个建边的零件个数少的那个
,然后建立源点汇点,源点连接p全为0的零件, p全为1的连接汇点,然后就可以用sap算法得到最大流,就是可以组装成的最多
的机器个数了,输出最大机器数量以及每条边流量
 
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

const int maxn=1e5+5;
const int inf=0x3f3f3f3f;
using namespace std;
struct Edge
{
    int to,next,cap,capp;
} edge[maxn];
int tot,head[maxn];
int gap[maxn],dis[maxn],pre[maxn],cur[maxn];
void init()
{
    tot=0;
    memset(head,-1,sizeof(head));
}
void addedge(int u,int v,int cap)
{
    edge[tot].to=v;
    edge[tot].cap=cap;
    edge[tot].next=head[u];
    edge[tot].capp=cap;
    head[u]=tot++;

    edge[tot].to=u;
    edge[tot].cap=0;
    edge[tot].capp=0;
    edge[tot].next=head[v];
    head[v]=tot++;
}

int sap(int start,int end,int nodenum)
{
    memset(dis,0,sizeof(dis));
    memset(gap,0,sizeof(gap));
    memcpy(cur,head,sizeof(head));
    int u=pre[start]=start;
    int maxflow=0,aug=-1;

    gap[0]=nodenum;
    while(dis[start]<nodenum)
    {
        //cout<<"fsfg"<<endl;
         loop:
        for(int &i=cur[u]; i!=-1; i=edge[i].next)
        {
            int v=edge[i].to;
            if(edge[i].cap&&dis[u]==dis[v]+1)
            {
                if(aug==-1||aug>edge[i].cap)
                    aug=edge[i].cap;
                pre[v]=u;
                u=v;
                if(v==end)
                {
                    maxflow+=aug;
                    for(u=pre[u]; v!=start; v=u,u=pre[u])
                    {
                        edge[cur[u]].cap-=aug;
                        edge[cur[u]^1].cap+=aug;
                    }
                    aug=-1;
                }
                goto loop;

            }

        }

        int mindis=nodenum;
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].to;
            if(edge[i].cap&&mindis>dis[v])
            {
                cur[u]=i;
                mindis=dis[v];
            }
        }
        if((--gap[dis[u]])==0)break;
        gap[dis[u]=mindis+1]++;
        u=pre[u];
    }
    return maxflow;
}

int meg[60][15];
int out[maxn][5],tol;
int main()
{
    int p,n;
    while(scanf("%d%d",&p,&n)!=-1)
    {
        int S,T;
        init();
        S=0;
        T=n+1;
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<2*p+1;j++)
            scanf("%d",&meg[i][j]);
        }
        for(int i=1;i<=n;i++)
        {
            int flags=1,flagd=1;
            for(int j=1;j<p+1;j++)
            {
                if(meg[i][j]==1)
                    flags=0;
                if(meg[i][j+p]==0)
                    flagd=0;
            }
            if(flags)
                addedge(S,i,meg[i][0]);
            if(flagd)
                addedge(i,T,meg[i][0]);
            int flag;
            for(int k=1;k<=n;k++)
            {
                if(k!=i)
                {
                    flag=1;
                     for(int j=1;j<p+1&&flag;j++)
                     if(meg[i][j+p]+meg[k][j]==1)
                        flag=0;
                    if(flag)
                        addedge(i,k,min(meg[i][0],meg[k][0]));
                }
            }
        }
       
        tol=0;
        int maxflow=sap(0,n+1,n+2);
        for(int u=1;u<=n;u++)
        {
            for(int i=head[u];i!=-1;i=edge[i].next)
            {
                int v=edge[i].to;
                if(v==S||v==T)
                    continue;
                if(edge[i].capp>edge[i].cap)
                {
                     out[tol][0]=u;
                     out[tol][1]=v;
                     out[tol++][2]=edge[i].capp-edge[i].cap;
                }

            }
        }
        printf("%d %d\n",maxflow,tol);
        for(int i=0;i<tol;i++)
        {
            printf("%d %d %d\n",out[i][0],out[i][1],out[i][2]);
        }
    }
    return 0;
}


 
 
 






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值