hdu5375 dp

C - Gray code
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems. 



Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai. 
Can you tell me how many points you can get at most? 

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4. 

Input

The first line of the input contains the number of test cases T. 

Each test case begins with string with ‘0’,’1’ and ‘?’. 

The next line contains n (1<=n<=200000) integers (n is the length of the string). 

a1 a2 a3 … an (1<=ai<=1000) 

Output

For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most

Sample Input

2
00?0
1 2 4 8
????
1 2 4 8

Sample Output

Case #1: 12
Case #2: 15

        
  

Hint

     
     
https://en.wikipedia.org/wiki/Gray_code

http://baike.baidu.com/view/358724.htm

题意:给一个 0 1 ? 字符串 ,又给一个长度为n 的序列a[],n=字符串长度,字符串中的?可以当做0也可以当做1,将这个字符串的“?”落实为1 或0 后将其转化为格雷码,格雷码第i为为1 ,则得到a[i]点值,问最大可以得到做少值

二进制码转化为格雷码,最左边位不变,然后每一位与其左边为异或得到该位格雷码,那么用一个二维数组dp[i] [0,1],表示第i位为 1 或为0 是最大的和;

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
using namespace std;
const int maxn=1e6,inf=0x3f3f3f3f;
int a[maxn];
char str[maxn];
int dp[maxn][2];
///dp[i][0] 表示第i项是0 的最大和 dp[i][1]表示第i项是1 的最大和
int main()
{
    int T=1,t;
    int n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",str);
        n=strlen(str);
        for(int i=0;i<n;i++)
        scanf("%d",&a[i]);
        dp[0][1]=dp[0][0]=-inf;
        if(str[0]=='1'||str[0]=='?')
            dp[0][1]=a[0];
        if(str[0]=='0'||str[0]=='?')
            dp[0][0]=0;

        for(int i=1;i<n;i++)
        {
            dp[i][0]=dp[i][1]=-inf;
            if(str[i]=='1'||str[i]=='?')///当前为为1或? 
                dp[i][1]=max(dp[i-1][0]+a[i],dp[i-1][1]);
            ///上一位是0 + 当前a[i] 值,上一位是1 异或为0 不加a[i]
            if(str[i]=='0'||str[i]=='?')
                dp[i][0]=max(dp[i-1][1]+a[i],dp[i-1][0]);
        }
        printf("Case #%d: %d\n",T++,max(dp[n-1][0],dp[n-1][1]));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值