hdu2577

M - How to Type
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input

The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output

For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input

     
     
3 Pirates HDUacm HDUACM
 

Sample Output

     
     
8 8 8

Hint

The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8


题意:cathy 打字,有大写字母也有小写字母,她想尽可能少的敲键盘,可以按大写锁定键,可以按Shift键来进行敲字母

输出最少按键次数,注意,最后大写锁定键灯必须是灭的;

我们可以用两个数组表示大写锁定键的灯的状态,然后递推得到最小结果

具体见代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
int min(int a,int b)
{
    if(a<b)
        return a;
    return b;
}
int main()
{
    char str[105];
    int dpa[105],dpA[105];
    int t,i;
    cin>>t;
    while(t--)
    {
        scanf("%s",str+1);
        memset(dpa,0,sizeof(dpa));
        memset(dpA,0,sizeof(dpA));
        dpa[0]=0,dpA[0]=1;///dpa表示灯灭,dpA表示灯亮
        for( i=1;str[i];i++)
        {
            if(str[i]>='a'&&str[i]<='z')
            {
                dpa[i]=min(dpa[i-1]+1,dpA[i-1]+2);///现在是小写,我们想让等
                ///继续灭着,那么可以是从灯灭的状态得来,然后加一,或者灯是亮的,按cape再按字母
                dpA[i]=min(dpa[i-1]+2,dpA[i-1]+2);
                ///现在想让灯亮,可以从灯灭dpa的得来,按cape再按字母键
                ///或者从灯亮的得来,按shift再按字母
            }
            else if(str[i]>='A'&&str[i]<='Z')
            {
                dpa[i]=min(dpa[i-1]+2,dpA[i-1]+2);
                dpA[i]=min(dpa[i-1]+2,dpA[i-1]+1);
            }
        }

        cout<<min(dpA[i-1]+1,dpa[i-1])<<endl;///最后大写锁定键灯要灭掉,+1
        

    }
   // cout << "Hello world!" << endl;
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值