03-树2 List Leaves (25 point(s))

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:
4 1 5

思路如下:
要求的是将叶子节点安装从上到下、从左至右的顺序输出,就要使用层序遍历的方法对二叉树进行遍历,在队列进行出队操作(pop)时,对出队节点的左右孩子是否为空进行判断,若为空则打印出该节点在数组中的位置;若不为空,则将其孩子节点入队(push)。
本题读取数据和找到二叉树根节点的思路和03-树1 树的同构 (25 point(s))的思路类似。

代码如下:

#include <iostream>
#include <stdio.h>
#include <queue>

using namespace std;
typedef struct BiTree *BT;
struct BiTree {
	int left;
	int right;
};
queue<int> queueList;
int cnt = 0;

void readTree(BiTree bt[], int len);
int findRoot(BiTree bt[], int len);
void findLeaves(BiTree bt[], int root);

int main() {
	int len;
	BiTree *bt;

	cin >> len;
	if (len != 0) {
		bt = (BiTree*)malloc(len * sizeof(BiTree));
		readTree(bt, len);
		int root = findRoot(bt, len);
		findLeaves(bt, root);
	}
	return 0;
}

void readTree(BiTree bt[], int len) {
	char left, right;
	for (int i = 0; i < len; i++) {
		cin >> left >> right;
		if (left != '-')
			bt[i].left = left - '0';
		else
			bt[i].left = -1;
		if (right != '-')
			bt[i].right = right - '0';
		else
			bt[i].right = -1;
	}
}
int findRoot(BiTree bt[], int len) {
	int record[10] = { 0 };
	for (int i = 0; i < len; i++) {
		if (bt[i].left != -1)
			record[bt[i].left] = 1;
		if (bt[i].right != -1)
			record[bt[i].right] = 1;
	}
	for (int i = 0; i < len; i++)
		if (record[i] == 0)
			return i;
	return -1;
}
void findLeaves(BiTree bt[], int root) {
	//使用层序遍历的思想,将整个二叉树遍历一遍,将左右儿子都为空的节点打印出来
	//每碰到一个节点将它的左右孩子入队(若有的话),然后依次从队头取出判断是否为叶子节点
	int temp;
	if (root == -1) return;
	queueList.push(root);
	while (!queueList.empty()) {
		temp = queueList.front();
		queueList.pop();
		if (bt[temp].left == -1 && bt[temp].right == -1) { //如果出队的节点左右孩子为空
			if (cnt++ != 0) printf(" "); //不是第一个节点的话,输出空格作为分隔符
			printf("%d", temp);
		}
		if (bt[temp].left != -1) queueList.push(bt[temp].left);
		if (bt[temp].right != -1) queueList.push(bt[temp].right);
	}
}

测试结果:
在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值