南阳oj 一种排序 题目5

给大家推荐个靠谱的公众号程序员探索之路,大家一起加油

/*
Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB

难度:3

描述 Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.输出For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.样例输入3
11
1001110110
101
110010010010001
1010
110100010101011
样例输出3
0
3
来源网络上传者naonao*/
#include<stdio.h>
#include<stdlib.h>
#define N 1000
#include<string.h>
using namespace std;
char a[N],b[10];
int main()
{
 int n;
 scanf("%d",&n);
 while(n--)
 {
  int k1,k2,sum=0,l,i,j;
  scanf("%s",b);
  scanf("%s",a);
  k1=strlen(a);
  k2=strlen(b);
  for(i=0;(i+k2-1)<k1;i++)
  {
    l=i;//记录i的值
    for(j=0;j<k2;j++)
    {
           if(b[j]==a[i]) i++;//如果相等i也要往后走
           else break;//不想等就结束
    }
          i=l;
          if(j==k2) sum++;//j之和k2相等就是说明全部匹配
  }
  printf("%d\n",sum);
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值