POJ 1573 (模拟)

题目:

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0
Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)

题目大意:先 输入N,M,S。表示有一个n*m的地图,有一个机器人从第1行的第S位置进入,每个格子中会有一个指令方向(东西南北,也就是上下左右),机器人会按照指令走一格。如果机器人走出地图输出:多少步走出去“  step(s) to exit”,如果机器人陷入一个循环输出:“        step(s) before a loop of        step(s)”表示第几步开始陷入了这个循环和这个循环的大小。

思路:
由于本人搜索不精,被搜索吓得看到就怂了,开始还以为这个是搜索,后来又看了看,纯模拟也可以过,这里就只给出模拟的代码了,搜索博主还不会写那个。。。代码如下:

#include<iostream>  
#include<cstdio>  
#include<cstring>   
using namespace std;  
const int MAXN = 1005;  
int n, m, s, step[MAXN][MAXN];  
string a[MAXN];  
bool vis[MAXN][MAXN];  
int main()  
{  
    while (~scanf("%d%d%d", &n, &m, &s) && n &&m && s)  
    {  
        memset(vis, 0, sizeof(vis));  
        memset(step, 0, sizeof(step));  
        for (int i = 0; i < n; i++) 
		cin >> a[i];  
        int x = 0, y = s - 1, t = 0;  
        while (1)  
        {  
            if (x < 0 || y < 0 || x >= n || y >= m)  
            {  
                printf("%d step(s) to exit\n", t);  
                break;  
            }  
            if (vis[x][y])  
            {  
                printf("%d step(s) before a loop of %d step(s)\n", step[x][y], t - step[x][y]);  
                break;  
            }  
            vis[x][y] = true; 
			step[x][y] = t;  
            if (a[x][y] == 'N') 
			x--, t++;  
            else if (a[x][y] == 'S') 
			x++, t++;  
            else if (a[x][y] == 'W') 
			y--, t++;  
            else if (a[x][y] == 'E') 
			y++, t++;  
  
        }  
    }  
    return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值