Euclid's Game POJ - 2348

题目:
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
         25 7

11 7
4 7
4 3
1 3
1 0

an Stan wins.
Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
Sample Input
34 12
15 24
0 0
Sample Output
Stan wins
Ollie wins


题意:这是个博弈论的题,就是有两个数在,前边的是Uruguay小于后边的数,换一下位置再相减,不然直接相减。
思路:这是一个规律题,我们可以先来列举一下 Stan wins胜的情况,当第一个的数是第二个的二倍或者大于二倍时候或者他们两个数相等的情况下 Stan wins肯定能赢:
然后就是看他们一共操作了多少步,若为奇数步依然是 Stan wins 能赢,不然就是偶数步的时候就是 Ollie wins 能赢,输出一下就可以了,当然这一题还有个坑就是最好用  long  long  博主用int错了好多发才发现。。。。。

     
下面看一下ac代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

long long cnt ,a , b;
void f(long long x , long long y )
{
	cnt ++ ;
	if(x == y || x >= 2 * y )
	return ;
	else
	f(y , x - y) ;
}

int main()
{
	while(scanf("%lld %lld",&a,&b),a+b){
			cnt = 0 ;
			if(a < b)
			swap(a , b);
			f(a , b);
		if(cnt%2!=0) 
		printf("Stan wins\n");  
        else 
		printf("Ollie wins\n"); 
		}
	return 0 ;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值