Beauty Contest POJ - 2187 旋转卡壳

 

题目:

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates.

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms.
 

Input

* Line 1: A single integer, N

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other.

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2

Hint

Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2)

 

题意:寻找平面最近点对

 

思路这是一个凸包问题的变形,在凸包上顺时针转边,找最远点,叉积相当于面积,因为底相同,比较叉积就相当于比较了高的距离就可以了,于是就可以以O(n) ,因为同一方向转的时候,当前点离边比下一个点近,必然离刚才边绕着同一方向的下一跳边更近凸包(0—top) 处理共线:<= 把中间共线部分去掉。  博主是套的模板就过了,,,看看ac代码。

 

 

#include<iostream>
#include<math.h>
#include<algorithm>
#include<stdlib.h>
using namespace std ;

struct Point{
	int x , y ;
	Point(int _x = 0 , int _y = 0 )
	{
		x = _x ;
		y = _y;
	}
	Point operator -(const Point &b)const
	{
		return Point(x-b.x,y-b.y);
	}
	int operator ^(const Point &b)const
	{
		return x * b.y- y * b.x;
	}
	int operator *(const Point &b)const
	{
		return x*b.x + y*b.y;
	}
	void input(){
		scanf("%d%d",&x,&y);
	}
};

int dist2(Point a , Point b ){
	return (a-b)*(a-b);
}

const int MAXN = 50010 ;
Point list[MAXN];
int Stack[MAXN],top;

bool _cmp(Point p1 , Point p2){
	int tmp = (p1-list[0])^(p2-list[0]);
	if(tmp > 0 )
	return true ;
	else if(tmp == 0 && dist2(p1,list[0]) <= dist2(p2,list[0]))
	return true ;
	else
	return false ;
}

void Graham(int n ){
	Point p0;
	int k = 0 ;
	p0 = list[0];
	for(int i = 1 ; i < n ; i ++)
	if(p0.y>list[i].y || (p0.y == list[i].y && p0.x > list[i].x))
	{
		p0 = list[i];
		k = i ;
	}
	swap(list[k],list[0]);
	sort(list+1,list+n,_cmp);
	if(n == 1)
	{
		top = 1 ;
		Stack[0] = 0 ;
		return ;
	}
	if(n == 2 )
	{
		top = 2 ;
		Stack[0] = 0 ;
		Stack[1] = 1 ;
		return ;
	}
	Stack[0] = 0 ;
	Stack[1] = 1 ;
	top = 2 ;
	for(int i = 2 ; i < n ; i ++)
	{
		while(top>1&&((list[Stack[top-1]] - list[Stack[top-2]]) ^ (list[i] - list[Stack[top-2]])) <= 0)
		top --;
		Stack[top++] = i ;
	}
}


int rotaing_calipers(Point p[] , int n )
{
	int  ans = 0 ;
	Point v;
	int cur = 1 ;
	for(int i = 0 ; i < n ; i ++){
		v = p[i] - p[(i+1)%n];
		while((v^(p[(cur+1)%n] - p[cur])) < 0)
		cur = (cur + 1) % n ;
		ans = max(ans,max(dist2(p[i],p[cur]) , dist2(p[(i+1)%n],p[(cur+1)%n])));
	}
	return ans ;
}


Point p[MAXN];
int main()
{
	int n ;
	while(scanf("%d",&n) == 1)
	{
		for(int i = 0 ; i < n ; i ++)
		list[i].input();
		Graham(n);
		for(int i = 0 ; i < top ; i ++)
		p[i] = list[Stack[i]];
		printf("%d\n",rotaing_calipers(p,top));
	}
	return 0 ;
}

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值