poj2187 Beauty Contest 凸包

Description

Bessie, Farmer John’s prize cow, has just won first place in a bovine beauty contest, earning the title ‘Miss Cow World’. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 … 10,000. No two farms share the same pair of coordinates.

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms.

Input

  • Line 1: A single integer, N

  • Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm
    Output

  • Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other.
    Sample Input

4
0 0
0 1
1 1
1 0
Sample Output

2

凸包求直径,凸包上距离最远的两个点的距离的平方。。。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
using namespace std;
#define MAX 50005
#define INF 1000000000
int n,L;
struct point  //构造点
{
    double x,y;
}p[MAX];
point save[50005];  //存点
int xmult(point p1,point p2,point p0)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
bool cmp(const point& a,const point &b)
{
    if(a.y == b.y)return a.x < b.x;
    return a.y < b.y;
}
int Graham(point *p,int n)
{
    int i;
    sort(p,p + n,cmp);
    save[0] = p[0];
    save[1] = p[1];
    int top = 1;
    for(i = 2;i < n; i++)
    {
        while(top && xmult(save[top],p[i],save[top-1])>=0) top--;//去掉=就是包含共线。。
        save[++top] = p[i];
    }
    int mid = top;
    for(i = n - 2; i >= 0; i--)
    {
        while(top>mid&&xmult(save[top],p[i],save[top-1])>=0) top--;//去掉=就是包含共线。。
        save[++top]=p[i];
    }
    return top;
}
double dis(point a,point b)
{
    double x=a.x-b.x;
    double y=a.y-b.y;
    return x*x+y*y;
}
int main()
{
    scanf("%d",&n);
    int i,j;
    for(i=0;i<n;i++) scanf("%lf %lf",&p[i].x,&p[i].y);
    int tot=Graham(p,n);
    double ans=0;
    for(i=0;i<tot;i++)
    {
        for(j=i;j<tot;j++)
        {
            ans=max(ans,dis(save[i],save[j]));
        }
    }
    printf("%.0f\n",ans);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值